Bug 621912 - selinux prevents httpd to load after setup install
Summary: selinux prevents httpd to load after setup install
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
(Show other bugs)
Version: 540
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Garik Khachikyan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: sat540-blockers
TreeView+ depends on / blocked
 
Reported: 2010-08-06 13:34 UTC by Shannon Hughes
Modified: 2015-01-04 21:57 UTC (History)
4 users (show)

Fixed In Version: oracle-selinux-0.1-23.16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 14:48:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
installation log (210.84 KB, application/octet-stream)
2010-08-06 13:34 UTC, Shannon Hughes
no flags Details

Description Shannon Hughes 2010-08-06 13:34:07 UTC
Created attachment 437144 [details]
installation log

Description of problem:
httpd will not start post setup due to selinux rules. attaching log of install. 

[Fri Aug 06 01:53:44 2010] [error] Can't load '/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/DBD/Oracle/Oracle.so' for module DBD::Oracle: /usr/lib/oracle/10.2.0.4/client/lib/libnnz10.so: cannot restore segment prot after reloc: Permission denied at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/DynaLoader.pm line 230.\n at /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB.pm line 515\nCompilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB.pm line 515.\nBEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB.pm line 515.\nCompilation failed in require at /etc/rhn/satellite-httpd/conf/startup.pl line 5.\nBEGIN failed--compilation aborted at /etc/rhn/satellite-httpd/conf/startup.pl line 5.\nCompilation failed in require at (eval 2) line 1.\n
[Fri Aug 06 01:53:44 2010] [error] Can't load Perl file: /etc/rhn/satellite-httpd/conf/startup.pl for server rlx-3-14.rhndev.redhat.com:0, exiting...

Comment 1 Michael Mráka 2010-08-09 09:02:33 UTC
According to /var/log/rhn/rhn-installation.log there was a problem with selinux-policy:

Transaction Summary
=============================================================================
Install    283 Package(s)         
Update      19 Package(s)         
Remove       0 Package(s)         

Total download size: 1.2 G
Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 37017186
Importing GPG key 0x37017186 "Red Hat, Inc. (release key) <security@redhat.com>"
Running Transaction Test
libsepol.context_from_record: type oracle_port_t is not defined
libsepol.context_from_record: could not create context structure
libsepol.port_from_record: could not create port structure for range 1521:1521 (tcp)
libsepol.sepol_port_modify: could not load port range 1521 - 1521 (tcp)
libsemanage.dbase_policydb_modify: could not modify record value
libsemanage.semanage_base_merge_components: could not merge local modifications into pol
icy
/usr/sbin/semanage: Could not add port tcp/1521
/sbin/restorecon:  error while labeling files under /usr/lib/oracle/10.2.*/client*
/sbin/restorecon:  error while labeling files under /etc/rc.d/np.d
...

The issue might be caused by wrong order of packages (selinux-policy-targeted went before oracle-*-selinux packages):
...
^M  Updating  : libselinux                   ##################### [ 12/321] 
^M  Installing: libselinux-utils             ##################### [ 13/321] 
^M  Updating  : libselinux-python            ##################### [ 37/321] 
^M  Updating  : selinux-policy               ##################### [192/321] 
^M  Installing: oracle-nofcontext-selinux    ##################### [203/321]libsepol.per
mission_copy_callback: Module oracle-nofcontext depends on permission dccp_recv in class
 node, not satisfied
^M  Installing: oracle-instantclient-selinux ##################### [218/321]/sbin/restor
econ reset /usr/lib/oracle/10.2.0.4/client/lib/libocci.so.10.1 context system_u:object_r
:lib_t:s0->system_u:object_r:textrel_shlib_t:s0
^M  Installing: oracle-rhnsat-selinux        ##################### [275/321]libsepol.per
mission_copy_callback: Module oracle-rhnsat depends on permission dccp_recv in class nod
e, not satisfied
^M  Installing: jabberd-selinux              ##################### [277/321]libsepol.per
mission_copy_callback: Module jabber depends on permission dccp_recv in class node, not 
satisfied
^M  Updating  : selinux-policy-targeted      ##################### [278/321]/sbin/restor
econ reset /etc/alsa/pcm context system_u:object_r:etc_t:s0->system_u:object_r:alsa_etc_
rw_t:s0
...


Reassigning to Jan.

Comment 2 Jan Pazdziora 2010-08-09 09:46:56 UTC
Fixed in Spacewalk master, 02a968f255bf5838a95ab923cddb50aab6840b1a.

Comment 4 Garik Khachikyan 2010-08-30 12:59:46 UTC
# VERIFIED

Checked against provided current latest ISO: Satellite-5.4.0-RHEL5-re20100827.0-x86_64.iso

it fixes the issues (no more error in rhn-installation.log) - httpd gets started after installation.

Comment 9 Tomas Lestach 2010-10-21 14:11:12 UTC
* installation without issues
* httpd runs after installation
# /etc/init.d/httpd status
httpd (pid  18174) is running...
* no issues in the log:
# grep oracle_port_t /var/log/rhn/rhn-installation.log
#
# grep "could not" /var/log/rhn/rhn-installation.log
# 

STAGE VALIDATED on Satellite-5.4.0-RHEL5-re20101019.0

Comment 10 Clifford Perry 2010-10-28 14:44:16 UTC
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford


Note You need to log in before you can comment on or make changes to this bug.