Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621944 - RHEL4 guest fails to boot after upgrade due to lack of virt* modules
RHEL4 guest fails to boot after upgrade due to lack of virt* modules
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.9
All Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-06 11:15 EDT by Dan Yasny
Modified: 2013-07-02 03:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-01 16:50:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yasny 2010-08-06 11:15:20 EDT
Description of problem:

The issue is that when updating a RHEL4 system to the latest kernel up2date fails to rebuild the initrd of the system to include the virt* modules required for the VM to boot correctly.

The missing modules required to make initrd correctly boot the system are :

--with=virtio_pci --with=virtio_net --with=virtio_blk --with=virtio_ring --with=virtio


Version-Release number of selected component (if applicable):
4.9

How reproducible:
always

Steps to Reproduce:
1.take 4.8, run up2date and get a new kernel
2.
3.
  
Actual results:
no boot

Expected results:
normal boot

Additional info:
the system is a kvm guest with virtio_blk and virtio_net interfaces

Note You need to log in before you can comment on or make changes to this bug.