Bug 621978 - [RFE] glibc could have a nss_init call that's like res_init but for nsswitch.conf
Summary: [RFE] glibc could have a nss_init call that's like res_init but for nsswitch....
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Andreas Schwab
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-06 16:49 UTC by Ray Strode [halfline]
Modified: 2016-11-24 16:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-29 05:18:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 12459 None None None Never

Description Ray Strode [halfline] 2010-08-06 16:49:43 UTC
Right now, long running processes don't get updates to the nsswitch module list in /etc/nsswitch.conf if nscd isn't running.  This causes a problem for GDM if the user logs in and runs authconfig and then logs out.

See bug 621700 for more details.

Comment 2 RHEL Product and Program Management 2010-08-06 17:07:23 UTC
This feature request has been proposed after Feature Freeze and we
are unable to resolve it in time for the current Red Hat Enterprise
Linux release. It has been denied for the current release and
proposed for the next Red Hat Enterprise Linux release.

Comment 3 Eric Bachalo 2010-12-01 16:47:33 UTC
We prefer glibc features be accepted upstream before patching into rhel glibc.

Comment 4 Ray Strode [halfline] 2010-12-01 18:20:52 UTC
sure makes sense.  will you handle making sure this gets requested upstream?

Comment 8 Ray Strode [halfline] 2011-02-02 17:05:38 UTC
I've filed this upstream here:

http://sourceware.org/bugzilla/show_bug.cgi?id=12459

Comment 9 Suzanne Yeghiayan 2011-03-28 20:26:24 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains 
unresolved, it has been rejected as it is not proposed as an 
exception or blocker.  It has been moved to RHEL 6.2 since 
it is a FutureFeature request.

Comment 10 Ray Strode [halfline] 2011-03-29 05:18:06 UTC
I don't actually have a specific need for this in RHEL, since I've worked around the issue.

Let's close this UPSTREAM so it's not floating on anyone's radar


Note You need to log in before you can comment on or make changes to this bug.