Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621998 - hearbeats are broken
hearbeats are broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: python-qpid (Show other bugs)
beta
All Linux
low Severity high
: 1.3
: ---
Assigned To: Rafael H. Schloming
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-06 14:00 EDT by Rafael H. Schloming
Modified: 2012-12-11 14:26 EST (History)
2 users (show)

See Also:
Fixed In Version: python-qpid-0.7.946106-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 14:26:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael H. Schloming 2010-08-06 14:00:55 EDT
Description of problem:

The client blows up when heartbeats are enabled (i.e. when receiving a heartbeat from the server). Also the client doesn't actually check that heartbeats are received at the appropriate interval. This is problematic for reconnect since this is necessary to ensure that dead TCP connections are detected, something that is necessary for reconnect to function properly in all cases.

Version-Release number of selected component (if applicable):

python-qpid-0.7.946106-11

How reproducible:

100%

Steps to Reproduce:

1. create a connection with the heartbeat parameter specified, e.g:

  conn = Connection(..., heartbeat=1)

2. wait for a heartbeat to arrive from the server (logging may be useful to verify that this is/has happened)
  
Actual results:

client blows up with an internal error


Expected results:

client should function normally

Note You need to log in before you can comment on or make changes to this bug.