Bug 622001 - nip2 bundles private fork of gtkextra
nip2 bundles private fork of gtkextra
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nip2 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Benjamin Gilbert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2010-08-06 14:08 EDT by Adam Goode
Modified: 2012-11-08 00:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 20:36:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Goode 2010-08-06 14:08:16 EDT
Description of problem:
nip2 contains a private fork of gtkextra.


Version-Release number of selected component (if applicable):
This is true as of 7.22.2.
Comment 1 Thom Carlin 2011-02-18 18:12:52 EST
Adam, any updates?
Comment 2 Adam Goode 2011-02-20 13:28:26 EST
Just sort of left here for now:
https://www.jiscmail.ac.uk/cgi-bin/webadmin?A2=VIPSIP;bb1d0df6.1007
Comment 3 Thom Carlin 2011-02-22 13:03:07 EST
Since that link was from last July, can you ping upstream? 

This bug is part of an FES ticket: https://fedorahosted.org/fedora-engineering-services/ticket/39

http://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries
Comment 4 Thom Carlin 2011-03-14 15:14:28 EDT
Adam, please respond to Comment 3 so I can update FES ticket 39.
Comment 5 Adam Goode 2011-03-14 21:42:50 EDT
Ok, I am checking.
Comment 6 Adam Goode 2011-03-16 23:03:21 EDT
Here is the reply:
https://www.jiscmail.ac.uk/cgi-bin/webadmin?A2=VIPSIP;52b56b38.1103
Comment 7 Thom Carlin 2011-04-26 07:26:20 EDT
Adam, any progress?
Comment 8 Adam Goode 2011-05-03 10:40:08 EDT
Sorry, I am totally behind on this. I need to push out the new version which has at least a partial fix for this.
Comment 9 Thom Carlin 2011-07-31 20:04:06 EDT
Another bump
Comment 10 Adam Goode 2011-08-12 14:43:33 EDT
With 7.24 in rawhide now, it's better but still not perfect.
Comment 11 Thom Carlin 2011-10-01 06:04:36 EDT
Hi Adam,  what remains to resolve this?
Comment 12 Benjamin Gilbert 2012-10-20 12:38:04 EDT
The remaining piece is a modified version of the GtkSheet widget.  Upstream says the original is ill-behaved when embedded into another widget as nip2 does.  Upstream isn't satisfied with the forked version, either, and wants to find an alternative when nip2 is ported to gtk3.  So hopefully this is not a long-term problem.

nip2 has a compile-time option to disable GtkSheet and fall back to GtkTreeView, at some cost in functionality.  I propose to enable the fallback beginning in F18.
Comment 13 Fedora Update System 2012-10-22 18:47:54 EDT
nip2-7.28.5-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nip2-7.28.5-1.fc18
Comment 14 Fedora Update System 2012-11-08 00:37:04 EST
nip2-7.28.5-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.