Bug 622013 - Group list under Activaion Key -> Groups -> Join displayed in random order
Summary: Group list under Activaion Key -> Groups -> Join displayed in random order
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 530
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Dimitar Yordanov
URL:
Whiteboard:
Keywords: EasyFix, Patch
Depends On:
Blocks: sat54-blockers
TreeView+ depends on / blocked
 
Reported: 2010-08-06 18:45 UTC by Xixi
Modified: 2018-11-14 17:27 UTC (History)
3 users (show)

(edit)
When associating system groups with an activation key, the previous version of the web user interface listed the groups in random order. This update adapts the web user interface to list the groups in alphabetical order.
Clone Of:
(edit)
Last Closed: 2011-09-05 07:10:00 UTC


Attachments (Terms of Use)
AddGroupsAction.java.TEST.1233343.1.patch (656 bytes, patch)
2010-08-06 18:51 UTC, Xixi
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1252 normal SHIPPED_LIVE Red Hat Network Satellite server spacewalk-java bug fix and enhancement update 2011-09-05 07:07:28 UTC

Description Xixi 2010-08-06 18:45:54 UTC
Description of problem:
On Satellite 5.3, when editing an activation key, under Groups -> Join section  the groups are displayed in random order (unsorted). It has only one field displayed which is Group Name and hence it should be by default sorted. It should not be displayed in any random order.

Version-Release number of selected component (if applicable):
Red Hat Network (RHN) Satellite 5.3.0

How reproducible:
Always.

Steps to Reproduce:
1. Have a 5.3 Satellite with >5-6 system groups created with different names
2. Edit any existing activation key -> Groups -> Join
3. Check the ordering of Group Names

Actual results:
Group list in random order (unsorted).

Expected results:
Group list sorted alphabetically by name.

Additional info:

Comment 1 Xixi 2010-08-06 18:47:30 UTC
This seems to be caused by frontend.action.token.groups.AddGroupsAction not sorting the List of groups. Proposed patch attached.

Comment 2 Xixi 2010-08-06 18:51:04 UTC
Created attachment 437236 [details]
AddGroupsAction.java.TEST.1233343.1.patch

Comment 3 Xixi 2010-08-06 18:53:38 UTC
On second thought, I'm not sure if the method getResults() is only called when the page is first displayed.  If that's not the case please ignore the patch (since it may cause it to always to be sorted in ascending order which means users can't sort it in reverse).

Comment 7 Tomas Lestach 2011-07-21 12:36:02 UTC
spacewalk.git: bc660584149d08b2ce141a033bb26a77e76b6903

Comment 11 Tomas Lestach 2011-08-16 13:23:00 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Consequence:
When associating system groups with an activation key, system groups were sorted in a random order.
Result:
Now the system groups are sorted in alphabetical order.

Comment 12 Dimitar Yordanov 2011-08-26 10:49:22 UTC
Verified RHEL5/6

Comment 13 Jaromir Hradilek 2011-08-31 13:14:59 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1 @@
-Consequence:
+When associating system groups with an activation key, the previous version of the web user interface listed the groups in random order. This update adapts the web user interface to list the groups in alphabetical order.-When associating system groups with an activation key, system groups were sorted in a random order.
-Result:
-Now the system groups are sorted in alphabetical order.

Comment 14 errata-xmlrpc 2011-09-05 07:10:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1252.html


Note You need to log in before you can comment on or make changes to this bug.