Bug 622043 - Rhythmbox builds against both GTK 2.0 and 3.0; will not run
Rhythmbox builds against both GTK 2.0 and 3.0; will not run
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 650924 652756 674478 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-06 17:12 EDT by W. Michael Petullo
Modified: 2011-02-16 00:47 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-07 21:27:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to build rhythmbox against GTK 3.0 (1.98 KB, application/octet-stream)
2010-08-06 17:12 EDT, W. Michael Petullo
no flags Details
RPM specification to build Rhythmbox with GTK 3.0 (37.19 KB, text/plain)
2010-08-06 18:09 EDT, W. Michael Petullo
no flags Details

  None (edit)
Description W. Michael Petullo 2010-08-06 17:12:36 EDT
Created attachment 437264 [details]
Patch to build rhythmbox against GTK 3.0

Description of problem:
The Rawhide rhythmbox package installs a rhythmbox that links agains both GTK 2.0 and 3.0.

Version-Release number of selected component (if applicable):
rhythmbox-0.13.0-4.fc14.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Install and run rhythmbox
  
Actual results:
$ rhythmbox

Gtk-ERROR **: GTK+ 3 symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
aborting...
Trace/breakpoint trap

Expected results:
Rhythmbox should run.

Additional info:
Comment 1 W. Michael Petullo 2010-08-06 18:09:29 EDT
Created attachment 437272 [details]
RPM specification to build Rhythmbox with GTK 3.0

A bit of a kludge. Does not build modules that need pygtk2. Runs ./autogen.sh before ./configure.
Comment 2 W. Michael Petullo 2010-09-08 13:32:04 EDT
See also https://bugzilla.gnome.org/show_bug.cgi?id=625942.
Comment 3 Tom London 2010-09-21 14:15:28 EDT
Was happily running with the above patch until latest update to gtk[23]:

gtk2-2.21.8-1.fc15.x86_64
gtk2-2.21.8-1.fc15.i686
gtk3-2.90.7-1.fc15.x86_64

Now I see:
rhythmbox: symbol lookup error: /usr/lib64/librhythmbox-core.so.0: undefined symbol: gdk_threads_lock
Comment 4 Jon Masters 2010-11-08 19:49:29 EST
*** Bug 650924 has been marked as a duplicate of this bug. ***
Comment 5 Jon Masters 2010-11-08 19:50:00 EST
There was an update to rhythmbox today, but it does not correct the problem. It still falls over instantly without starting with this error.
Comment 6 Jon Masters 2010-11-08 19:56:53 EST
I take that back, the latest rhythmbox didn't install due to a dependency problem. I will wait for that to be resolved.
Comment 7 Tom London 2010-11-13 12:48:06 EST
Continues to crash at startup with rhythmbox-0.13.2-2.fc15.x86_64:

[tbl@tlondon ~]$ rhythmbox

Gtk-ERROR **: GTK+ 3 symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
aborting...
Trace/breakpoint trap (core dumped)
[tbl@tlondon ~]$ 

rhythmbox-0.13.2-2.fc15.x86_64
gtk3-2.91.4-2.fc15.x86_64
gtk2-2.23.2-1.fc15.x86_64
gtk2-2.23.2-1.fc15.i686
Comment 8 Bastien Nocera 2010-11-16 05:33:36 EST
*** Bug 652756 has been marked as a duplicate of this bug. ***
Comment 9 Filipe Rosset 2010-12-29 05:21:25 EST
I can confirm still crashes in my system.

[filiper@rosset-laptop ~]$ rpm -q rhythmbox
rhythmbox-0.13.2-2.fc15.x86_64
[filiper@rosset-laptop ~]$ rpm -q gtk2
gtk2-2.23.2-1.fc15.x86_64
[filiper@rosset-laptop ~]$ rpm -q gtk3
gtk3-2.91.5-1.fc15.x86_64
[filiper@rosset-laptop ~]$ 

[filiper@rosset-laptop ~]$ rhythmbox

Gtk-ERROR **: GTK+ 3 symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
aborting...
Trace/breakpoint trap (core dumped)
[filiper@rosset-laptop ~]$
Comment 10 Peter Hjalmarsson 2010-12-30 01:26:50 EST
$ ldd /usr/bin/rhythmbox | grep gtk
	libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x0000003912200000)
	libgtk-x11-3.0.so.0 => /usr/lib64/libgtk-x11-3.0.so.0 (0x000000391a600000)

I think that describes the problem better.

However I guess this will not be fixed unless a bump is done upstream? I think I saw some work getting done in the upstream git repo, but I do not know if it is enought and if it works.
Comment 11 Adam Williamson 2010-12-30 10:34:09 EST
there's really no need at all to append comments to this bug, it's perfectly well known and being worked on upstream that rhythmbox needs to be ported to GTK+ 3. commenting on this downstream bug doesn't achieve anything. if you wish to follow the work, follow the upstream tracker bug - https://bugzilla.gnome.org/show_bug.cgi?id=625942 .



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Jon Masters 2011-01-05 01:03:36 EST
Adam, I consider this a distribution bug. Packages that are rebuilt but fail to even load (or are built against incompatible libraries) should not be shipped, and should be replaced with older working versions. I realize the automated infrastructure can't detect this problem, but plenty of developers have seen it, so I think it would be reasonable to revert to an older version for now.
Comment 13 Adam Williamson 2011-01-05 05:39:31 EST
I don't believe that's possible. Some of the things RB builds against are themselves now built against GTK+ 3, so we can't just do a GTK+ 2-only build of RB. The only fix for this is a GTK+ 3 build.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Jon Masters 2011-01-11 01:33:46 EST
Respectfully, I disagree. There are two correct ways to fix this problem:

1). Library rebases of this type (major) should keep an older library version around for existing packages to use. Other distributions do this. We are basically one of the only ones out there claiming it's a good idea only to support one version of a library at a time.

2). Group updates to such packages in rawhide, such that they *all* land at the same time, or don't land, and they are known to work before they go out. Really, there's no reason to have software that doesn't even load.

Not picking on RB in particular, but to say this isn't a solvable problem or that the only solution is to rebuild against a new library isn't true IMO.

Jon.
Comment 15 Adam Williamson 2011-01-11 05:09:48 EST
Bugzilla is not the place to discuss general issues of packaging philosophy; it'd be better suited to a mailing list.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Jon Masters 2011-01-11 11:14:36 EST
Sure. I've raised this stuff previously, and I don't see anything changing. But yea, can stop discussing it here I suppose.
Comment 17 Joachim Frieben 2011-01-16 11:43:47 EST
Issue still applies to rhythmbox-0.13.3-1.fc15.
Comment 18 Bastien Nocera 2011-02-07 21:27:44 EST
This is fixed in rawhide.
Comment 19 Bastien Nocera 2011-02-07 21:39:21 EST
*** Bug 674478 has been marked as a duplicate of this bug. ***
Comment 20 David Le Sage 2011-02-16 00:47:54 EST
FWIW, I just tried the F15 Alpha TC2 live CD


http://alt.fedoraproject.org/pub/alt/stage/15-Alpha.TC2/Live/


and I can confirm that Rhythmbox now launches against GNOME 3.0.

Note You need to log in before you can comment on or make changes to this bug.