Bug 622052 - Intel 82Q35 not working on primary display
Intel 82Q35 not working on primary display
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
6.0
i686 Linux
low Severity high
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: RHELNAK, Triaged
Depends On:
Blocks: 662543 842499
  Show dependency treegraph
 
Reported: 2010-08-06 17:48 EDT by Jos Vos
Modified: 2012-08-07 00:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-12 14:57:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (176.90 KB, text/plain)
2010-08-23 11:10 EDT, Jos Vos
no flags Details
/var/log/messages (86.96 KB, text/plain)
2010-08-23 11:12 EDT, Jos Vos
no flags Details
/var/log/Xorg.0.log (37.42 KB, text/plain)
2010-08-23 11:13 EDT, Jos Vos
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 29449 None None None Never

  None (edit)
Description Jos Vos 2010-08-06 17:48:38 EDT
The primary display IBM point-of-sale system (SurePOS 566) with an Intel 82Q35 graphics chipset does not work on RHEL6 and F13, but it does work fine on SLED 11 (older software).  OpenSUSE 11.3 seems to face the same problem.  The system has a 15" display (touchscreen) directly attached and also a VGA port for a second display (to which I have connected a monitor now).

The dmesg output of RHEL6b2 (with my own comment inserted):

i915 0000:00:02.0: LVDS-1: EDID block 1 invalid.
fbcon: inteldrmfb (fb0) is primary device
###### HERE THE CONSOLE SWITCHES FROM PRIMARY TO SECONDARY DISPLAY !!! ######
Console: switching to colour frame buffer device 160x64
fb0: inteldrmfb frame buffer device
drm: registered panic notifier
Slow work thread pool: Starting up
Slow work thread pool: Ready
No ACPI video bus found
[drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0

From the marked moment, all output is shown on the secondary display, including subsequent X session.

In the dmesg output I also see:

[drm] set up 7M of stolen space
[drm:intel_init_bios] *ERROR* VBT signature missing
[drm] failed to find VBIOS tables

And many messages like this:

[drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 226
[drm:drm_edid_block_valid] *ERROR* Raw EDID:

I can prevent the console switch by adding the "nomodeset" kernel parameter, but then X won't start at all.

Relevant packages versions:
kernel-2.6.32-44.1.el6.i686
xorg-x11-drv-intel-2.11.0-6.el6.i686
Comment 2 RHEL Product and Program Management 2010-08-06 18:07:50 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Jos Vos 2010-08-11 12:14:27 EDT
This bug can be found upstream here:

https://bugs.freedesktop.org/show_bug.cgi?id=29449
Comment 4 Matěj Cepl 2010-08-23 10:51:28 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Jos Vos 2010-08-23 11:10:15 EDT
Created attachment 440407 [details]
dmesg output

Output of "dmesg" when booting (with an additional 1280x1024 monitor connected, besides the primary 1024x768 display that is attached to the system).
Comment 6 Jos Vos 2010-08-23 11:12:27 EDT
Created attachment 440408 [details]
/var/log/messages

Contents of /var/log/messages when booting (with an additional 1280x1024 monitor connected, besides the primary 1024x768 display that is attached to the system).
Comment 7 Jos Vos 2010-08-23 11:13:52 EDT
Created attachment 440410 [details]
/var/log/Xorg.0.log

Contents of /var/log/Xorg.0.log when booting (with an additional 1280x1024 monitor connected, besides the primary 1024x768 display that is attached to the system).
Comment 8 Jos Vos 2010-08-23 11:21:38 EDT
The 3 new attachments are logs from the normal boot situation with "drm.debug=0x04" (and without "rhgb quiet"), where the kernel output at some point switches to the secondary display (I think when modeset is done) and gives a graphical display there.

In the meantime I've found a workaround for working with the VESA driver: specify "nomodeset vga=0x318" (without vga=0x318 this is NOT working, as the VESA driver then says it can't find a BIOS table or so) as kernel parameters and create an xorg.conf file specifying the "vesa" driver.

Furthermore, I've not found a similar workaround to make a graphical install possible with anaconda using the primary screen.
Comment 9 RHEL Product and Program Management 2011-01-07 11:00:22 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 10 RHEL Product and Program Management 2011-02-01 01:06:16 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 11 RHEL Product and Program Management 2011-02-01 13:32:36 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 12 RHEL Product and Program Management 2011-04-03 22:34:16 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 13 RHEL Product and Program Management 2011-10-07 12:14:49 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 14 Adam Jackson 2012-07-12 14:57:42 EDT
The DRM in RHEL 6.3 includes the upstream fix for this issue.

Note You need to log in before you can comment on or make changes to this bug.