Bug 622077 - [PATCH] Don't force GUI dialog if TTY available
[PATCH] Don't force GUI dialog if TTY available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pinentry (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-07 00:22 EDT by Ben Boeckel
Modified: 2011-08-16 21:21 EDT (History)
3 users (show)

See Also:
Fixed In Version: pinentry-0.8.1-4.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-16 21:12:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patched pinentry launcher (2.12 KB, application/octet-stream)
2010-08-07 00:22 EDT, Ben Boeckel
no flags Details

  None (edit)
Description Ben Boeckel 2010-08-07 00:22:56 EDT
Created attachment 437299 [details]
patched pinentry launcher

Description of problem:
When using gpg in a terminal, it detects that $DISPLAY is set and passes it along to pinentry. The wrapper script then errors out about no GUI pinentry existing when pinentry-ncurses would work fine. This patch should work, but since I also don't have any GUI applications that use GPG, I cannot really fully test it. Testing it without applying and installing it involves:

1. Comment out the check for $PINENTRY_BINARY and the corresponding 'fi'
2. Get an encrypted file (gpg --encrypt $file > $file.gpg)
3. Decrypt with:
    PINENTRY_BINARY=/path/to/patched/pinentry gpg --decrypy $file.gpg > /dev/null
4. pinentry-ncurses should pop up.

Another thing that needs to be tested is:

    PINENTRY_BINARY=/path/to/patched/pinentry gui-app

where gui-app requires a pinentry dialog for some action. Doing this from the command line should *not* result in pinentry-ncurses popping up in the terminal and should instead fail if there are no GUI pinentry dialogs installed. This can be simulated by commenting out the relevant if branches.

Version-Release number of selected component (if applicable):
pinentry-0.8.0-3.fc13.x86_64
Comment 1 Fedora Update System 2011-07-26 05:00:39 EDT
pinentry-0.8.1-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pinentry-0.8.1-4.fc14
Comment 2 Fedora Update System 2011-07-26 05:01:50 EDT
pinentry-0.8.1-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/pinentry-0.8.1-4.fc15
Comment 3 Stanislav Ochotnicky 2011-07-26 05:05:12 EDT
Sorry it took so long. This is indeed a nice fallback mechanism that should have been there in the beginning. I applied this to all current Fedoras (F14+). If you feel like it, you can test the update for F14/15.
Comment 4 Fedora Update System 2011-07-31 00:02:19 EDT
Package pinentry-0.8.1-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pinentry-0.8.1-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/pinentry-0.8.1-4.fc15
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2011-08-16 21:12:33 EDT
pinentry-0.8.1-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2011-08-16 21:21:07 EDT
pinentry-0.8.1-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.