Bug 622179 - (yum-auto-close) failed to install signature: Traceback (most recent call last):
failed to install signature: Traceback (most recent call last):
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
14
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
/etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x...
: Reopened
: 627355 628114 628228 628355 630395 637211 643783 (view as bug list)
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-08-07 18:53 EDT by Dave Galloway
Modified: 2014-01-21 18:16 EST (History)
27 users (show)

See Also:
Fixed In Version: yum-3.2.28-5.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-23 00:57:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmfusion instalation (4.18 KB, text/plain)
2010-09-01 14:09 EDT, Rafael Louback Ferraz
no flags Details
yum update (6.18 KB, text/plain)
2010-09-01 14:12 EDT, Rafael Louback Ferraz
no flags Details

  None (edit)
Description Dave Galloway 2010-08-07 18:53:52 EDT
Description of problem:  I can't install any software,  all have the same errors.
Trying to add qtparted and gparted and others but it won't install.

I have no idea what to do with this...


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Repository name:  		fedora
Signature URL: 			/etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64
Signature User Identifier:	Fedora (13) <fedora@fedoraproject.org>
Signature Identifier:		E8E40FDE
Package:			jfsutils-1.1.13-8.fc12.x86_64


failed to install signature: Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2926, in install_signature
    self.yumbase.getKeyForPackage(pkg, askcb = lambda x, y, z: True)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 4309, in getKeyForPackage
    result = ts.pgpImportPubkey(misc.procgpgkey(info['raw_key']))
  File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 59, in __getattr__
    return self.getMethod(attr)
  File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 69, in getMethod
    return getattr(self.ts, method)
AttributeError: 'NoneType' object has no attribute 'pgpImportPubkey'




I wish I knew how to fill this out properly.   I need the class.
Comment 1 caughtflying 2010-08-11 05:54:07 EDT
i have the same problem
Comment 2 seth vidal 2010-08-12 12:03:37 EDT
thanks - found it - a patch applied on monday apparently didn't catch this case.

Fixed in upstream.
Comment 3 Fedora Update System 2010-08-12 16:15:10 EDT
yum-3.2.28-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/yum-3.2.28-3.fc12
Comment 4 Fedora Update System 2010-08-12 16:17:40 EDT
yum-3.2.28-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/yum-3.2.28-3.fc13
Comment 5 Fedora Update System 2010-08-12 16:20:03 EDT
yum-3.2.28-3.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/yum-3.2.28-3.fc14
Comment 6 Fedora Update System 2010-08-13 17:18:10 EDT
yum-3.2.28-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/yum-3.2.28-3.fc12
Comment 7 Fedora Update System 2010-08-17 01:45:19 EDT
yum-3.2.28-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-08-19 22:18:43 EDT
yum-3.2.28-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Andre Klapper 2010-08-22 10:51:52 EDT
I run into exactly the same update with today's Fedora13 updates available (specifically: ffmpeg and friends). Stacktrace is nearly identical except for linenumber in the getKeyForPackage() call.

$:andre\> rpm -q yum
yum-3.2.28-3.fc13.noarch


failed to install signature: Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2926, in install_signature
    self.yumbase.getKeyForPackage(pkg, askcb = lambda x, y, z: True)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 4329, in getKeyForPackage
    result = ts.pgpImportPubkey(misc.procgpgkey(info['raw_key']))
  File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 59, in __getattr__
    return self.getMethod(attr)
  File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 69, in getMethod
    return getattr(self.ts, method)
AttributeError: 'NoneType' object has no attribute 'pgpImportPubkey'
Comment 10 Simon Barnes 2010-08-22 12:42:46 EDT
This problem is associated with the RPMFUSION and EHEL repository packages.

The workaround for this is to use command line yum with the --nogpgcheck option.

It is nevertheless irritating.
Comment 11 Fedora Update System 2010-08-23 21:36:42 EDT
yum-3.2.28-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Simon Barnes 2010-08-24 05:47:00 EDT
As you can see yum is already at that release

[simon@lefthand-pc ~]$ rpm -q yum
yum-3.2.28-3.fc13.noarch

yum is failing to install update for rpmfusion and ehal repositories.

It gives the error below:

failed to install signature: Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2926, in install_signature
    self.yumbase.getKeyForPackage(pkg, askcb = lambda x, y, z: True)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 4329, in getKeyForPackage
    result = ts.pgpImportPubkey(misc.procgpgkey(info['raw_key']))
  File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 59, in __getattr__
    return self.getMethod(attr)
  File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 69, in getMethod
    return getattr(self.ts, method)
AttributeError: 'NoneType' object has no attribute 'pgpImportPubkey'
Comment 13 ISO 2010-08-24 11:09:16 EDT
I have the same problem. I applies not only to RPMFusion but also to the Adobe repository. This makes me think it is a general problem in installing new signatures.

Here is the output I got when I tried to update RPMFusion

failed to install signature: Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2926, in install_signature
    self.yumbase.getKeyForPackage(pkg, askcb = lambda x, y, z: True)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 4329, in getKeyForPackage
    result = ts.pgpImportPubkey(misc.procgpgkey(info['raw_key']))
  File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 59, in __getattr__
    return self.getMethod(attr)
  File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 69, in getMethod
    return getattr(self.ts, method)
AttributeError: 'NoneType' object has no attribute 'pgpImportPubkey'
Comment 14 Rafael Louback Ferraz 2010-08-24 17:01:38 EDT
Im using yum 3.2.28-3.fc13 in fc13, and the problem with rpmfusion persists. Here is the error message

failed to install signature: Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2926, in install_signature
    self.yumbase.getKeyForPackage(pkg, askcb = lambda x, y, z: True)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 4329, in getKeyForPackage
    result = ts.pgpImportPubkey(misc.procgpgkey(info['raw_key']))
  File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 59, in __getattr__
    return self.getMethod(attr)
  File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 69, in getMethod
    return getattr(self.ts, method)
AttributeError: 'NoneType' object has no attribute 'pgpImportPubkey'
Comment 15 Andre Klapper 2010-08-24 17:14:05 EDT
Folks, please avoid posting the same stuff over and over again.
The same stacktrace has now been posted four times, a simply "Same as in comment X" would have been enough. Thanks... :)
Comment 16 Rafael Louback Ferraz 2010-08-24 17:38:11 EDT
sorry about that
Comment 17 seth vidal 2010-08-25 15:23:26 EDT
I can't make this happen at all on my f13 box running the same yum version with rpmfusion or adobe's repositories.


Is it only happening in PK?
Comment 18 S P Arif Sahari Wibowo 2010-09-01 12:50:14 EDT
I am experiencing this as well:

# rpm -q yum
yum-3.2.28-3.fc13.noarch
# cat /etc/redhat-release
Fedora release 13 (Goddard)
# uname -srvmpio
Linux 2.6.33.8-149.fc13.i686.PAE #1 SMP Tue Aug 17 22:39:27 UTC 2010 i686 i686 i386 GNU/Linux
Comment 19 seth vidal 2010-09-01 12:57:28 EDT
Is it happening for you in yum or only in PackageKit?
Comment 20 Rafael Louback Ferraz 2010-09-01 13:28:11 EDT
I tried to install rpmfusion repositories by commmand line, and the error happens too.
Comment 21 seth vidal 2010-09-01 13:31:09 EDT
the exact same output? Can you attach the complete output from the command line?

thanks
Comment 22 Rafael Louback Ferraz 2010-09-01 13:40:12 EDT
The problem is, I already validate rpmfusion repositories importing the gpgkey manually. How I remove it to try to install again?
Comment 23 seth vidal 2010-09-01 13:42:50 EDT
install the yum-plugin-keys

then do

yum keys-list
Comment 24 Rafael Louback Ferraz 2010-09-01 13:45:22 EDT
The problem is, I already validate rpmfusion repositories importing the gpgkey manually. How I remove it to try to install again?
Comment 25 Rafael Louback Ferraz 2010-09-01 13:49:00 EDT
I installed the software. But how I remove the key?
Comment 26 Rafael Louback Ferraz 2010-09-01 14:09:24 EDT
Created attachment 442459 [details]
rpmfusion instalation
Comment 27 Rafael Louback Ferraz 2010-09-01 14:12:50 EDT
Created attachment 442460 [details]
yum update

Sorry but the log is in portuguese. But I think that the critial part is:

aviso: rpmts_HdrFromFdno: Cabeçalho V3 RSA/SHA256 Signature, key ID 2425b284: NOKEY
rpmfusion-nonfree/gpgkey                                                                                                      | 3.4 kB     00:00 ... 
Importing GPG key 0x2425B284:
 Userid : RPM Fusion nonfree repository for Fedora (13) <rpmfusion-buildsys@lists.rpmfusion.org>
 Package: rpmfusion-nonfree-release-11-2.noarch (@/rpmfusion-nonfree-release-stable.noarch)
 From   : /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-13-i386
Comment 28 Rafael Louback Ferraz 2010-09-01 14:16:29 EDT
ps: running yum update by commmand line, it worked
Comment 29 seth vidal 2010-09-01 16:28:19 EDT
From what I can tell it is only happening when PK runs yum in its backend, then. Is that consistent with what you see Rafael?
Comment 30 Rafael Louback Ferraz 2010-09-01 20:22:13 EDT
Seems that way Seth. But this NOKEY message isnt the problem?

like we can see in:
aviso: rpmts_HdrFromFdno: Cabeçalho V3 RSA/SHA256 Signature, key ID 2425b284: NOKEY


ps: aviso is equal to warning
Comment 31 seth vidal 2010-09-02 10:18:26 EDT
No that warning just says:
 "we attempted to open the rpm, noticed we do not have a gpg key for it and now we are going to download the gpg keys we know about and try it again"

it's legit and not a worry.
Comment 32 Rob 2010-09-02 12:17:30 EDT
I just replaced fc11 with fc13 and got the same error as originally reported.

Installing the plugin keys corrected the problem.

Thanks.
Comment 33 Rafael Louback Ferraz 2010-09-02 18:57:32 EDT
installing the keys plugin solves the problem to use in packagekit too? or just in yum?
Comment 34 Rob 2010-09-02 20:29:40 EDT
Just to yum in my case.

(In reply to comment #33)
> installing the keys plugin solves the problem to use in packagekit too? or just
> in yum?
Comment 35 seth vidal 2010-09-02 22:56:37 EDT
Richard,
 I'm not positive this is a PK yum-backend bug at all but I'm having a hard time replicating it NOT in PK and apparently so are the users on this bug. i've looked at yum-backend but nothing leaps out at me for how this is happening. Could you take a look at it?

Thank You
Comment 36 Richard Hughes 2010-09-03 04:29:20 EDT
(In reply to comment #35)
> Richard,
>  I'm not positive this is a PK yum-backend bug at all but I'm having a hard
> time replicating it NOT in PK and apparently so are the users on this bug. i've
> looked at yum-backend but nothing leaps out at me for how this is happening.
> Could you take a look at it?

I've spent a few minutes checking out if PackageKit made any changes which might affect things, and PK hasn't changed any of the signature processing stuff since the end of F12.

Is there an easy way to reproduce this on a system with all the keys installed? If so, could the reporters please try with older versions of yum, say the yum that shipped in F13 (http://download.fedora.redhat.com/pub/fedora/linux/releases/13/Everything/i386/os/) -- if that works then bisecting yum to find the commit that broke things would be a (long but) good thing to do. The other thing would be to check the original version of PackageKit too, just to rule out anything odd.

If this is reproducible, I would think this should be a F14 blocker for sure.
Comment 37 seth vidal 2010-09-03 09:28:08 EDT
Richard,
 that's just it - The version of yum in f14 and that in f13, f12 are all the same now - 3.2.28-3. Afaict, the problem doesn't occur for 3.2.28-3 according to these users EXCEPT when PK is involved.


Does PK modify or close the rpmdb or ts objects for any particular reason in the middle of things? B/c that could impact this.
Comment 38 Richard Hughes 2010-09-06 04:03:44 EDT
(In reply to comment #37)
> Richard,
>  that's just it - The version of yum in f14 and that in f13, f12 are all the
> same now - 3.2.28-3. Afaict, the problem doesn't occur for 3.2.28-3 according
> to these users EXCEPT when PK is involved.

Right, but my point was it used to work...

> Does PK modify or close the rpmdb or ts objects for any particular reason in
> the middle of things? B/c that could impact this.

No, AFAIKS it does the request, then the transaction finishes.
Comment 39 Richard Hughes 2010-09-06 04:03:58 EDT
*** Bug 627355 has been marked as a duplicate of this bug. ***
Comment 40 Richard Hughes 2010-09-06 04:04:18 EDT
*** Bug 630395 has been marked as a duplicate of this bug. ***
Comment 41 Rafael Louback Ferraz 2010-09-06 11:16:36 EDT
(In reply to comment #36) 
> Is there an easy way to reproduce this on a system with all the keys installed?
> If so, could the reporters please try with older versions of yum, say the yum
> that shipped in F13
> (http://download.fedora.redhat.com/pub/fedora/linux/releases/13/Everything/i386/os/)


Reproduce this with the rpmfusion key already installed? If the key is already installed I dont receive any errors. Using PK or yum
Comment 42 Daniel Davies 2010-09-08 07:10:31 EDT
I am experiencing this bug on a fresh install of F13.

I configured the install to use the following repositories (in additon to the DVD) during the install:

Fedora13 - x86_64
Fedora13 - x86_64 - Updates

I then tried to install google chrome by downloading the RPM from the chrome page (google-chrome-stable_current_x86_64.rpm) I just double clicked

This failed with same failure to install signature

Repository name:    updates
Signature URL:    /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64
Signature User Identifier: Fedora (13) <fedora@fedoraproject.org>
Signature Identifier:  E8E40FDE
Package:   redhat-lsb-4.0-5.fc13.x86_64

I then tried to install the keys plugin using add/remove software and had a similar failure.

I then installed the keys plugin from the command line and it succeeded, after which I could install chrome.

Not sure why the command line succeeded.
Comment 43 Wendell Fields 2010-09-11 23:43:59 EDT
Downloaded Fedora 13 32-bit DVD, verified, installed.  First update of 22 packages:

failed to install signature: Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2926, in install_signature
    self.yumbase.getKeyForPackage(pkg, askcb = lambda x, y, z: True)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 4329, in getKeyForPackage
    result = ts.pgpImportPubkey(misc.procgpgkey(info['raw_key']))
  File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 59, in __getattr__
    return self.getMethod(attr)
  File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 69, in getMethod
    return getattr(self.ts, method)
AttributeError: 'NoneType' object has no attribute 'pgpImportPubkey'
Comment 44 Richard Hughes 2010-09-14 05:43:11 EDT
I started by rebuilding http://download.fedora.redhat.com/pub/fedora/linux/releases/13/Fedora/source/SRPMS/yum-3.2.27-4.fc13.src.rpm and installed it on F14. Installing a signature using the GUI tools then works.

Update yum to the version in F14 and it fails.

*** This is a yum regression ***

I have bisected it to the following patch in yum:

commit 148431f73fac6b0b2b9a67eb8f9617e79b7070e8
Author: James Antill <james@and.org>
Date:   Tue Jun 22 16:03:41 2010 -0400

    Make the "installing gpg key" messages nicer, showing the owning package.

If you revert this patch from yum-3_2_X then PackageKit works again. Please either fix the patch or revert it as otherwise F14 is going to break as soon as users try to install any other repository like rpmfusion and use any of the GUI tools.

I've marked this bug as an F14 blocker.

Richard.
Comment 45 Richard Hughes 2010-09-14 05:44:08 EDT
Ohh, and it looks like it's also broken F13.
Comment 46 Richard Hughes 2010-09-14 07:38:05 EDT
(In reply to comment #45)
> Ohh, and it looks like it's also broken F13.

And F12.
Comment 47 James Antill 2010-09-14 10:12:22 EDT
The problem is calling rpmdb.searchFiles() when auto_close is enabled, which then makes the ts we have invalid ... I have a fix to just always re-request the ts.
Comment 48 James Antill 2010-09-14 10:14:33 EDT
*** Bug 628228 has been marked as a duplicate of this bug. ***
Comment 49 Fedora Update System 2010-09-14 10:44:42 EDT
yum-3.2.28-5.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/yum-3.2.28-5.fc12
Comment 50 Fedora Update System 2010-09-14 10:59:05 EDT
yum-3.2.28-4.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/yum-3.2.28-4.fc13
Comment 51 Fedora Update System 2010-09-14 11:07:11 EDT
yum-3.2.28-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/yum-3.2.28-4.fc14
Comment 52 Wendell Fields 2010-09-14 14:46:28 EDT
 (In reply to comment #43)
I enabled the Updates repository when I installed F13.   I assume the updates that asked to be installed were in response to the enabling of the update repository??  Fyi in case this helps.  -WF

> Downloaded Fedora 13 32-bit DVD, verified, installed.  First update of 22
> packages:
> 
> failed to install signature: Traceback (most recent call last):
>   File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2926, in
> install_signature
>     self.yumbase.getKeyForPackage(pkg, askcb = lambda x, y, z: True)
>   File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 4329, in
> getKeyForPackage
>     result = ts.pgpImportPubkey(misc.procgpgkey(info['raw_key']))
>   File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 59, in
> __getattr__
>     return self.getMethod(attr)
>   File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 69, in
> getMethod
>     return getattr(self.ts, method)
> AttributeError: 'NoneType' object has no attribute 'pgpImportPubkey'

(In reply to comment #43)
> Downloaded Fedora 13 32-bit DVD, verified, installed.  First update of 22
> packages:
> 
> failed to install signature: Traceback (most recent call last):
>   File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2926, in
> install_signature
>     self.yumbase.getKeyForPackage(pkg, askcb = lambda x, y, z: True)
>   File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 4329, in
> getKeyForPackage
>     result = ts.pgpImportPubkey(misc.procgpgkey(info['raw_key']))
>   File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 59, in
> __getattr__
>     return self.getMethod(attr)
>   File "/usr/lib/python2.6/site-packages/rpmUtils/transaction.py", line 69, in
> getMethod
>     return getattr(self.ts, method)
> AttributeError: 'NoneType' object has no attribute 'pgpImportPubkey'
Comment 53 Fedora Update System 2010-09-15 01:27:13 EDT
yum-3.2.28-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/yum-3.2.28-5.fc12
Comment 54 Fedora Update System 2010-09-23 00:57:42 EDT
yum-3.2.28-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 55 Richard Hughes 2010-09-23 04:33:51 EDT
*** Bug 628355 has been marked as a duplicate of this bug. ***
Comment 56 Richard Hughes 2010-09-23 04:34:23 EDT
*** Bug 628114 has been marked as a duplicate of this bug. ***
Comment 57 Fedora Update System 2010-09-23 08:59:55 EDT
yum-3.2.28-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 58 Andre Klapper 2010-09-23 09:54:09 EDT
(In reply to comment #54)
> yum-3.2.28-4.fc13 has been pushed to the Fedora 13 stable repository

Confirming that it now works fine. Thanks for the fix!
Comment 59 James Antill 2010-09-27 09:07:37 EDT
*** Bug 637211 has been marked as a duplicate of this bug. ***
Comment 60 Girts 2010-09-29 14:45:26 EDT
I installed today Fedora 14 Beta and stil has this bug. I cannot install yum-3.2.28-4.fc14 from Software Update. Here is message:

failed to install signature: Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2937, in install_signature
    self.yumbase.getKeyForPackage(pkg, askcb = lambda x, y, z: True)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 4329, in getKeyForPackage
    result = ts.pgpImportPubkey(misc.procgpgkey(info['raw_key']))
  File "/usr/lib/python2.7/site-packages/rpmUtils/transaction.py", line 59, in __getattr__
    return self.getMethod(attr)
  File "/usr/lib/python2.7/site-packages/rpmUtils/transaction.py", line 69, in getMethod
    return getattr(self.ts, method)
AttributeError: 'NoneType' object has no attribute 'pgpImportPubkey'
Comment 61 Steve Tyler 2010-09-29 15:05:26 EDT
(In reply to comment #60)
> I installed today Fedora 14 Beta and stil has this bug. I cannot install
> yum-3.2.28-4.fc14 from Software Update. Here is message:
...

IIUC, if you installed from the DVD, this bug cannot be fixed.

A workaround is to update yum from a terminal window:
Bug 637211, Comment 4.

James: ISTM this would qualify for Common Bugs:
http://fedoraproject.org/wiki/Common_F14_bugs
Comment 62 Girts 2010-09-29 15:19:25 EDT
OK, but will it be fixed in final version?
Comment 63 Andre Klapper 2010-09-29 15:32:21 EDT
(In reply to comment #62)
> OK, but will it be fixed in final version?

Of course, see comment 51.
Comment 64 Fedora Update System 2010-09-30 06:34:01 EDT
yum-3.2.28-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 65 Richard Hughes 2010-10-18 04:34:08 EDT
*** Bug 643783 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.