Bug 622185 - SELinux is preventing /usr/sbin/sendmail.sendmail access to a leaked /root file descriptor.
Summary: SELinux is preventing /usr/sbin/sendmail.sendmail access to a leaked /root fi...
Keywords:
Status: CLOSED DUPLICATE of bug 621842
Alias: None
Product: Fedora
Classification: Fedora
Component: cronie
Version: 14
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:38abe190da9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-07 23:14 UTC by Adam Williamson
Modified: 2010-09-23 18:37 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-13 18:49:46 UTC


Attachments (Terms of Use)

Description Adam Williamson 2010-08-07 23:14:36 UTC
Summary:

SELinux is preventing /usr/sbin/sendmail.sendmail access to a leaked /root file
descriptor.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by the sendmail command. It looks like this is
either a leaked descriptor or sendmail output was redirected to a file it is not
allowed to access. Leaks usually can be ignored since SELinux is just closing
the leak and reporting the error. The application does not use the descriptor,
so it will run properly. If this is a redirection, you will not get output in
the /root. You should generate a bugzilla on selinux-policy, and it will get
routed to the appropriate package. You can safely ignore this avc.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385)

Additional Information:

Source Context                system_u:system_r:logwatch_mail_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root [ dir ]
Source                        sendmail
Source Path                   /usr/sbin/sendmail.sendmail
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           sendmail-8.14.4-9.fc14
Target RPM Packages           filesystem-2.4.35-1.fc14
Policy RPM                    selinux-policy-3.8.8-10.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   leaks
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.35-0.57.rc6.git1.fc14.x86_64 #1 SMP Mon Jul 26
                              22:43:02 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Sat 07 Aug 2010 03:17:04 AM PDT
Last Seen                     Sat 07 Aug 2010 03:17:04 AM PDT
Local ID                      2eac0d53-a0f4-48a2-826f-6d0cff118359
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1281176224.902:1623): avc:  denied  { read } for  pid=3092 comm="sendmail" path="/root" dev=dm-0 ino=49 scontext=system_u:system_r:logwatch_mail_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1281176224.902:1623): arch=c000003e syscall=59 success=yes exit=0 a0=7fff423a76c4 a1=2e86ad0 a2=2e87830 a3=8 items=0 ppid=2956 pid=3092 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=51 sgid=51 fsgid=51 tty=(none) ses=38 comm="sendmail" exe="/usr/sbin/sendmail.sendmail" subj=system_u:system_r:logwatch_mail_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  leaks,sendmail,logwatch_mail_t,admin_home_t,dir,read
audit2allow suggests:

#============= logwatch_mail_t ==============
allow logwatch_mail_t admin_home_t:dir read;

Comment 1 Daniel Walsh 2010-08-13 15:48:30 UTC
Caused by a cronn leak.

Comment 2 Daniel Walsh 2010-08-13 18:49:46 UTC

*** This bug has been marked as a duplicate of bug 621842 ***


Note You need to log in before you can comment on or make changes to this bug.