Bug 62220 - ATI Xpert 128 Installation Problem
ATI Xpert 128 Installation Problem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-28 10:11 EST by Brad Galbraith
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-30 10:12:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree Log (16.85 KB, text/plain)
2002-03-28 10:27 EST, Brad Galbraith
no flags Details
XF86Config file (14.57 KB, text/plain)
2002-03-28 10:28 EST, Brad Galbraith
no flags Details

  None (edit)
Description Brad Galbraith 2002-03-28 10:11:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Hotbar 3.0)

Description of problem:
Xconfigurator problem with ATI Xpert 128 Video Card. Error screen with "There 
is a problem with your configuration. You may go back... "

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
This is on a fully updated 7.2 sys as of 3/28/02. HW is a Dell 1300 Server 
(using as a workstation), dual PII 400, 256RAM. I added an ATI Xpert 128, 16mb, 
PCI video card to replace the onboard 2m video, no bios option to disable but 
obviously the card works as I have the monitor connected to the new card and 
can work in the shell.

When going through Xconfigurator the PCI Probe finds:
PCI Entry: ATI | Rage 128 PP (even thought it's an Expert)
X Server: XF86_SVGA
XFree4 driver: r128   (default)

It then finds my IBM G94 monitor ok
Monitor Name: IBM G94
Horizontal Sync Range: 30-95 kHz
Vertical Sync Range: 50-160 kHz

Then finds the correct video memory, 16mb. No clockchip settings. I have tried 
8, 16 and 24 bit video modes, all with the same results. I prefer 1024x768 or 
1280x1024 but tried 8 bit 640 and 800 resolutions.
	

Actual Results:  Once it tries to test and start the X server I get the above 
error message. 

Expected Results:  It should have started the Xserver and asked if I liked the 
resolution.

Additional info:

I have searched ATI's site, XFree and others, have found certain XF86Config 
file suggestions: http://www.xfree86.org/3.3.6/r1285.html#5 but doesn't work 
either. Basically, as it stands this card will not work. What is the fix?
Comment 1 Brad Galbraith 2002-03-28 10:12:25 EST
One other note, this very issue can be found with no results all over the 
Support Forum boards and other places on the web, I have never seen any kind of 
feedback from RH on this issue but seems to be rather rampant.
Comment 2 Mike A. Harris 2002-03-28 10:18:12 EST
Xpert is the card's marketing name used on the box, etc.
The card's chipset is "ATI | Rage 128 PP" identified by PCI ID 0x5050

I believe the problem is likely misconfiguration of either your hardware
in the CMOS or via jumpers, or misconfiguration of X.

Please attach your XFree86 config file and X server log using the file
attachment link below.
Comment 3 Brad Galbraith 2002-03-28 10:27:42 EST
Created attachment 51186 [details]
XFree Log
Comment 4 Brad Galbraith 2002-03-28 10:28:40 EST
Created attachment 51187 [details]
XF86Config file
Comment 5 Brad Galbraith 2002-03-28 11:00:22 EST
I have checked all of my cmos/bios settings, the board nor the card have 
jumpers to effect any settings related to this. I see where it is not 
recognizing the ChipId of 0x5050 in the log. I am sure open to suggestions.
Comment 6 Brad Galbraith 2002-03-30 10:12:10 EST
So what's the status on this? I haven't heard anything after I sent the config 
and log files.
Comment 7 Mike A. Harris 2002-03-31 07:53:38 EST
The status is what the bug report reads.  ASSIGNED.

XFree86 4.1.0 officially does not support this card upstream.  I personally
created a patch to support it, and that patch works for a few people, so
I opted to include it as a "hope this works for you" patch, figuring users
would prefer that to no support at all.

XFree86 4.2.0 now supports this card natively (with my patch, plus a few
other fixes), so I'm considering it fixed in rawhide.
Comment 8 Brad Galbraith 2002-04-01 02:53:50 EST
Where do I find your 'patch'? I would appreciate more information.

Note You need to log in before you can comment on or make changes to this bug.