Bug 622204 - nc should support ports and port ranges separated by commas
Summary: nc should support ports and port ranges separated by commas
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nc (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Petr Šabata
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-08 03:44 UTC by Jonathan Kamens
Modified: 2010-10-19 07:17 UTC (History)
2 users (show)

Fixed In Version: nc-1.84-23.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-13 12:46:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (2.82 KB, patch)
2010-08-08 03:44 UTC, Jonathan Kamens
no flags Details | Diff

Description Jonathan Kamens 2010-08-08 03:44:00 UTC
Created attachment 437403 [details]
patch

Wherever nc accepts a range of ports, it should also support one or more individual ports or port ranges separated by commas.

As it happens, this is very easy to implement with minor changes to a single function. I've attached a patch.

I can't figure out how to submit an upstream bug about this (the URL in the RPM appears to refer to a repository directory, not to a maintainer's web page), so I'm submitting the patch here. If you'd prefer for me to upstream it, just tell me how ;-).

The patch is a lot less ominous than it looks because I had to indent a big block of code which wasn't actually modified other than the indenting.

Comment 1 Fedora Admin XMLRPC Client 2010-09-02 14:11:36 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Petr Šabata 2010-10-08 13:56:30 UTC
Thanks Jonathan,

I've patched the man page as well. I won't submit those to the upstream developers for now since we currently have a really old version in Fedora. I plan to update to the latest snapshots and port our patches in the near future.

Comment 3 Fedora Update System 2010-10-08 14:07:15 UTC
nc-1.84-23.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/nc-1.84-23.fc13

Comment 4 Fedora Update System 2010-10-08 14:07:29 UTC
nc-1.84-23.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/nc-1.84-23.fc14

Comment 5 Fedora Update System 2010-10-08 20:54:37 UTC
nc-1.84-23.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nc'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/nc-1.84-23.fc13

Comment 6 Fedora Update System 2010-10-13 12:46:35 UTC
nc-1.84-23.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2010-10-19 07:17:46 UTC
nc-1.84-23.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.