Bug 622223 - abrt eats characters outside the basic latin range when submitting to bugzilla
abrt eats characters outside the basic latin range when submitting to bugzilla
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Denys Vlasenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Target
  Show dependency treegraph
 
Reported: 2010-08-08 03:51 EDT by Nicolas Mailhot
Modified: 2011-06-23 23:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: abrt-2.0.3-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-23 23:25:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2010-08-08 03:51:57 EDT
Description of problem:

As seen in bug #622222 abrt eats characters outside the basic latin range when submitting to bugzilla

That means text not written in English becomes unreadable, and it is not possible to sanely report distribution UTF-8 handling problems as abrt will eat the reproducer sequences

Version-Release number of selected component (if applicable):
abrt-1.1.10-4.fc14.x86_64
abrt-addon-ccpp-1.1.10-4.fc14.x86_64
abrt-addon-kerneloops-1.1.10-4.fc14.x86_64
abrt-addon-python-1.1.10-4.fc14.x86_64
abrt-desktop-1.1.10-4.fc14.x86_64
abrt-gui-1.1.10-4.fc14.x86_64
abrt-libs-1.1.10-4.fc14.x86_64
abrt-plugin-bugzilla-1.1.10-4.fc14.x86_64
abrt-plugin-logger-1.1.10-4.fc14.x86_64
abrt-plugin-runapp-1.1.10-4.fc14.x86_64
Comment 1 Denys Vlasenko 2010-08-17 08:36:40 EDT
(In reply to comment #0)
> Description of problem:
> 
> As seen in bug #622222 abrt eats characters outside the basic latin range when
> submitting to bugzilla

abrt eats characters outside the basic latin range - where exactly?
When you enter them in "how to reproduce" field in abrt's gui tool?
Or somewhere else?
Comment 2 Nicolas Mailhot 2010-08-17 08:53:03 EDT
In the comment and "how to reproduce"

And the command capture is strange (\xc3\xa9 instead of é)

You have various examples in bug #622222 where complémentaires is replaced by complmentaires or compl\xc3\xa9mentaires, and "font(écoliercourt)" by "font(coliercourt)"
Comment 3 Denys Vlasenko 2011-05-19 10:53:17 EDT
Found the bug.

Fixed it in git with commit f3b32f8cb94bc83ded97bec478e666be6a07bf0d.

This fixes all text fields except cmdline.

Cmdline will still look like 'compl\xc3\xa9mentaires'.

Why?

We want to be a bit more paranoid about this bit of data - that is, we want to be very sure reporter gets EXACT command line. Meaning: no hidden spaces (think how these two commands from shell:
 cmd "abc def"
 cmd abc def
can look very similar...), no hidden Unicode chars which look very similar to ASCII chars (or have zero width and are invisible), etc.

If you think we should not escape cmdline, please reopen this bug and explain why you think so.
Comment 4 Nicolas Mailhot 2011-05-25 03:11:15 EDT
Is there any way to convert this in a working command line ? Because otherwise, I fear a developper receiving an abrt report with munged cli will just ignore it
Comment 5 Fedora Update System 2011-06-21 09:45:27 EDT
abrt-2.0.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.3-1.fc15
Comment 6 Fedora Update System 2011-06-21 19:56:20 EDT
Package abrt-2.0.3-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.3-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/abrt-2.0.3-1.fc15
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2011-06-23 23:23:32 EDT
abrt-2.0.3-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.