Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 622232 - totem crash (segfault)
totem crash (segfault)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-08 05:08 EDT by Joachim Backes
Modified: 2010-08-19 01:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: gnome-panel-2.31.6-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 21:20:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f totem (script file) (942.33 KB, application/octet-stream)
2010-08-08 05:08 EDT, Joachim Backes
no flags Details
strace with totem-2.31.6-2.fc14.i686 (841.14 KB, application/octet-stream)
2010-08-14 03:16 EDT, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2010-08-08 05:08:00 EDT
Created attachment 437421 [details]
strace -f totem (script file)

Description of problem:
totem crash (segfault)

Version-Release number of selected component (if applicable):
totem-2.90.5-5.fc14.i686

How reproducible:
always

Steps to Reproduce:
1. Start totem by "totem" (without any options and files)
2.
3.
  
Actual results:
Segmentation fault

Expected results:
No crash

Additional info:
Comment 1 Joachim Backes 2010-08-10 09:53:09 EDT
On Aug,10 I run "yum update", After that, getting another error message when starting totem without any parameter and without any option:

---------------------------------------------------------------------------------
Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
aborting...
Trace/breakpoint trap (core dumped)
--------------------------------------------------------------------------------

yum log:

Aug 10 10:02:00 Installed: gtkglext-libs-1.2.0-10.fc12.i686
Aug 10 10:02:01 Installed: freeglut-2.6.0-5.fc14.i686
Aug 10 10:02:01 Installed: clutter-gtk-0.10.4-5.fc14.i686
Aug 10 10:02:07 Installed: PyOpenGL-3.0.0-3.fc14.noarch
Aug 10 10:02:08 Installed: pygtkglext-1.1.0-9.fc14.i686
Aug 10 10:02:11 Installed: 1:gnome-games-extra-2.31.5-2.fc14.i686
Aug 10 12:00:19 Installed: rpm-build-4.8.1-4.fc14.i686
Aug 10 12:13:30 Updated: glib2-2.25.13-1.fc14.i686
Aug 10 12:13:30 Updated: freetype-2.4.2-2.fc14.i686
Aug 10 12:13:32 Updated: 1:openoffice.org-ure-3.3.0-3.1.fc14.i686
Aug 10 12:13:37 Updated: GConf2-2.31.7-1.fc14.i686
Aug 10 12:13:37 Updated: libudev-160-9.fc14.i686
Aug 10 12:13:38 Updated: libgudev1-160-9.fc14.i686
Aug 10 12:13:41 Updated: gnome-desktop-2.31.6-1.fc14.i686
Aug 10 12:13:41 Installed: clutter-gst-1.0.0-1.fc14.i686
Aug 10 12:13:42 Updated: systemd-units-6-2.fc14.i686
Aug 10 12:13:44 Updated: udev-160-9.fc14.i686
Aug 10 12:13:45 Updated: device-mapper-libs-1.02.53-3.fc14.i686
Aug 10 12:13:45 Updated: device-mapper-1.02.53-3.fc14.i686
Aug 10 12:13:46 Updated: device-mapper-event-libs-1.02.53-3.fc14.i686
Aug 10 12:13:47 Updated: setools-libs-3.3.7-6.fc14.i686
Aug 10 12:13:47 Updated: setools-libs-python-3.3.7-6.fc14.i686
Aug 10 12:13:48 Updated: setools-console-3.3.7-6.fc14.i686
Aug 10 12:13:48 Updated: device-mapper-event-1.02.53-3.fc14.i686
Aug 10 12:13:48 Updated: lvm2-libs-2.02.72-3.fc14.i686
Aug 10 12:13:49 Updated: GConf2-gtk-2.31.7-1.fc14.i686
Aug 10 12:13:51 Updated: gnome-session-2.31.6-1.fc14.i686
Aug 10 12:13:51 Updated: gvnc-0.4.1-5.fc14.i686
Aug 10 12:13:53 Updated: policycoreutils-2.0.83-13.fc14.i686
Aug 10 12:13:53 Updated: policycoreutils-python-2.0.83-13.fc14.i686
Aug 10 12:13:54 Installed: clutter-gesture-0.0.2-2.fc13.i686
Aug 10 12:13:55 Updated: 1:gnome-utils-libs-2.31.1-2.fc14.i686
Aug 10 12:13:56 Installed: clutter-imcontext-0.1.6-3.fc14.i686
Aug 10 12:13:58 Installed: libmx-1.0.3-1.fc14.i686
Aug 10 12:13:59 Updated: newt-0.52.12-1.fc14.i686
Aug 10 12:13:59 Updated: newt-python-0.52.12-1.fc14.i686
Aug 10 12:13:59 Updated: transmission-common-2.04-1.fc14.i686
Aug 10 12:14:01 Updated: transmission-gtk-2.04-1.fc14.i686
Aug 10 12:14:02 Updated: cheese-2.31.1-1.fc14.i686
Aug 10 12:14:06 Updated: cheese-libs-2.31.1-1.fc14.i686
Aug 10 12:14:16 Updated: 1:gnome-utils-2.31.1-2.fc14.i686
Aug 10 12:14:17 Updated: gtk-vnc-0.4.1-5.fc14.i686
Aug 10 12:14:19 Updated: lvm2-2.02.72-3.fc14.i686
Aug 10 12:14:19 Updated: mdadm-3.1.3-0.git20100804.2.fc14.i686
Aug 10 12:14:20 Updated: systemd-6-2.fc14.i686
Aug 10 12:14:22 Updated: gconf-editor-2.31.6-1.fc14.i686
Aug 10 12:14:23 Updated: libpeas-0.5.4-1.fc14.i686
Aug 10 12:14:24 Updated: libwnck-2.30.3-1.fc14.i686
Aug 10 12:14:25 Updated: zenity-2.31.6-1.fc14.i686
Aug 10 12:14:26 Updated: telepathy-haze-0.4.0-1.fc14.i686
Aug 10 12:14:27 Updated: libgexiv2-0.1.90-2.fc14.i686
Aug 10 12:14:31 Updated: glib2-devel-2.25.13-1.fc14.i686
Aug 10 12:14:32 Updated: dbusmenu-qt-0.5.2-1.fc14.i686
Aug 10 12:14:33 Updated: python-ethtool-0.5-1.fc14.i686
Aug 10 12:14:33 Updated: soprano-2.5.0-1.fc14.i686
Aug 10 12:14:35 Updated: syslinux-4.02-1.fc14.i686
Aug 10 12:14:35 Updated: perf-2.6.35-3.fc14.i686
Aug 10 12:14:42 Updated: gnome-icon-theme-2.31.0-1.fc14.noarch
Aug 10 12:14:44 Updated: linux-firmware-20100806-2.fc14.noarch
Aug 10 12:14:46 Updated: 1:openoffice.org-opensymbol-fonts-3.3.0-3.1.fc14.noarch
Aug 10 12:14:46 Updated: 1:autocorr-en-3.3.0-3.1.fc14.noarch
Aug 10 12:14:50 Updated: system-config-date-1.9.60-1.fc14.noarch
Aug 10 12:14:51 Updated: policycoreutils-gui-2.0.83-13.fc14.i686
Aug 10 12:14:51 Updated: gnome-session-xsession-2.31.6-1.fc14.i686
Aug 10 12:14:52 Updated: freetype-devel-2.4.2-2.fc14.i686
Aug 10 12:14:54 Updated: system-config-language-1.3.4-6.fc14.noarch
Aug 10 12:14:55 Updated: 1:grub-0.97-66.fc14.i686
Aug 10 12:14:56 Updated: kernel-headers-2.6.35-3.fc14.i686
Aug 10 12:14:57 Updated: python-telepathy-0.15.18-1.fc14.noarch
Aug 10 12:15:10 Installed: kernel-devel-2.6.35-3.fc14.i686
Aug 10 12:15:39 Updated: 1:openoffice.org-core-3.3.0-3.1.fc14.i686
Aug 10 12:15:41 Updated: 1:openoffice.org-brand-3.3.0-3.1.fc14.i686
Aug 10 12:15:41 Updated: 1:openoffice.org-impress-core-3.3.0-3.1.fc14.i686
Aug 10 12:15:47 Updated: 1:openoffice.org-presenter-screen-3.3.0-3.1.fc14.i686
Aug 10 12:15:47 Updated: 1:openoffice.org-graphicfilter-3.3.0-3.1.fc14.i686
Aug 10 12:15:50 Updated: 1:openoffice.org-calc-core-3.3.0-3.1.fc14.i686
Aug 10 12:15:52 Updated: 1:openoffice.org-writer-core-3.3.0-3.1.fc14.i686
Aug 10 12:15:53 Updated: 1:openoffice.org-math-core-3.3.0-3.1.fc14.i686
Aug 10 12:15:53 Updated: nautilus-extensions-2.31.5-3.really.2.30.1.fc14.i686
Aug 10 12:16:00 Updated: nautilus-2.31.5-3.really.2.30.1.fc14.i686
Aug 10 12:16:00 Updated: 1:openoffice.org-writer-3.3.0-3.1.fc14.i686
Aug 10 12:16:01 Updated: 1:openoffice.org-calc-3.3.0-3.1.fc14.i686
Aug 10 12:16:01 Updated: 1:openoffice.org-impress-3.3.0-3.1.fc14.i686
Aug 10 12:16:11 Installed: kernel-2.6.35-3.fc14.i686
Aug 10 12:16:14 Updated: gnome-power-manager-2.31.6-3.fc14.i686
Aug 10 12:16:17 Updated: gnome-color-manager-2.31.6-2.fc14.i686
Aug 10 12:16:23 Updated: gnome-packagekit-2.31.6-2.fc14.i686
Aug 10 12:16:24 Updated: 1:openoffice.org-draw-core-3.3.0-3.1.fc14.i686
Aug 10 12:16:24 Updated: 1:openoffice.org-math-3.3.0-3.1.fc14.i686
Aug 10 12:16:24 Updated: 1:openoffice.org-langpack-en-3.3.0-3.1.fc14.i686
Aug 10 12:16:24 Updated: 1:openoffice.org-xsltfilter-3.3.0-3.1.fc14.i686
Aug 10 12:16:28 Updated: 1:openoffice.org-pdfimport-3.3.0-3.1.fc14.i686
Aug 10 12:16:28 Updated: 1:openoffice.org-draw-3.3.0-3.1.fc14.i686
Comment 2 Fedora Update System 2010-08-13 14:29:07 EDT
brasero-2.31.5-4.fc14,dconf-0.5-2.fc14,devhelp-2.31.6-3.fc14,epiphany-2.30.2-3.fc14,evince-2.31.6.1-1.fc14,file-roller-2.31.5-2.fc14,gedit-2.30.2-2.fc14,glib2-2.25.13-2.fc14,gnome-bluetooth-2.31.6-3.fc14,gnome-user-share-2.30.0-7.fc14,gobject-introspection-0.9.3-1.fc14,nautilus-sendto-2.31.6-3.fc14,seahorse-plugins-2.30.1-3.fc14,totem-2.31.6-2.fc14,yelp-2.30.1-4.fc14,rhythmbox-0.13.0-5.fc14,sound-juicer-2.31.6-1.fc14,gnome-media-2.31.6-1.fc14,gnome-panel-2.31.6-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/brasero-2.31.5-4.fc14,dconf-0.5-2.fc14,devhelp-2.31.6-3.fc14,epiphany-2.30.2-3.fc14,evince-2.31.6.1-1.fc14,file-roller-2.31.5-2.fc14,gedit-2.30.2-2.fc14,glib2-2.25.13-2.fc14,gnome-bluetooth-2.31.6-3.fc14,gnome-user-share-2.30.0-7.fc14,gobject-introspection-0.9.3-1.fc14,nautilus-sendto-2.31.6-3.fc14,seahorse-plugins-2.30.1-3.fc14,totem-2.31.6-2.fc14,yelp-2.30.1-4.fc14,rhythmbox-0.13.0-5.fc14,sound-juicer-2.31.6-1.fc14,gnome-media-2.31.6-1.fc14,gnome-panel-2.31.6-1.fc14
Comment 3 Joachim Backes 2010-08-14 03:16:04 EDT
After having updated to totem-2.31.6-2.fc14.i686, totem stillo crashes
Comment 4 Joachim Backes 2010-08-14 03:16:53 EDT
Created attachment 438785 [details]
strace with totem-2.31.6-2.fc14.i686
Comment 5 Martin Sourada 2010-08-14 06:14:31 EDT
(In reply to comment #4)
> Created attachment 438785 [details]
> strace with totem-2.31.6-2.fc14.i686

Yes, but due to different error, apparently. For me it's /usr/bin/totem: symbol lookup error: /usr/bin/totem: undefined symbol: totem_disc_media_type_get_type. I've created Bug 624197 for this issue.
Comment 6 Joachim Backes 2010-08-14 06:29:01 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > Created attachment 438785 [details] [details]
> > strace with totem-2.31.6-2.fc14.i686
> 
> Yes, but due to different error, apparently. For me it's /usr/bin/totem: symbol
> lookup error: /usr/bin/totem: undefined symbol: totem_disc_media_type_get_type.
> I've created Bug 624197 for this issue.

Additionally, having the same problem:

/usr/bin/totem

** (totem:11867): WARNING **: AT-SPI: Accessibility bus not found - Using session bus.

/usr/bin/totem: symbol lookup error: /usr/bin/totem: undefined symbol: totem_disc_media_type_get_type
Comment 7 Fedora Update System 2010-08-16 12:04:44 EDT
gnome-panel-2.31.6-1.fc14, totem-pl-parser-2.30.2-1.fc14, brasero-2.31.5-4.fc14, dconf-0.5-2.fc14, devhelp-2.31.6-3.fc14, epiphany-2.30.2-3.fc14, evince-2.31.6.1-1.fc14, file-roller-2.31.5-2.fc14, gedit-2.30.2-2.fc14, glib2-2.25.13-2.fc14, gnome-bluetooth-2.31.6-3.fc14, gnome-user-share-2.30.0-7.fc14, gobject-introspection-0.9.3-1.fc14, nautilus-sendto-2.31.6-3.fc14, seahorse-plugins-2.30.1-3.fc14, totem-2.31.6-2.fc14, rhythmbox-0.13.0-5.fc14, sound-juicer-2.31.6-1.fc14, yelp-2.30.1-4.fc14, gnome-media-2.31.6-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-panel totem-pl-parser brasero dconf devhelp epiphany evince file-roller gedit glib2 gnome-bluetooth gnome-user-share gobject-introspection nautilus-sendto seahorse-plugins totem rhythmbox sound-juicer yelp gnome-media'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/brasero-2.31.5-4.fc14,dconf-0.5-2.fc14,devhelp-2.31.6-3.fc14,epiphany-2.30.2-3.fc14,evince-2.31.6.1-1.fc14,file-roller-2.31.5-2.fc14,gedit-2.30.2-2.fc14,glib2-2.25.13-2.fc14,gnome-bluetooth-2.31.6-3.fc14,gnome-user-share-2.30.0-7.fc14,gobject-introspection-0.9.3-1.fc14,nautilus-sendto-2.31.6-3.fc14,seahorse-plugins-2.30.1-3.fc14,totem-2.31.6-2.fc14,yelp-2.30.1-4.fc14,rhythmbox-0.13.0-5.fc14,sound-juicer-2.31.6-1.fc14,gnome-media-2.31.6-1.fc14,gnome-panel-2.31.6-1.fc14,totem-pl-parser-2.30.2-1.fc14
Comment 8 Fedora Update System 2010-08-18 21:19:04 EDT
gnome-panel-2.31.6-1.fc14, totem-pl-parser-2.30.2-1.fc14, brasero-2.31.5-4.fc14, dconf-0.5-2.fc14, devhelp-2.31.6-3.fc14, epiphany-2.30.2-3.fc14, evince-2.31.6.1-1.fc14, gedit-2.30.2-2.fc14, glib2-2.25.13-2.fc14, gnome-bluetooth-2.31.6-3.fc14, gnome-user-share-2.30.0-7.fc14, gobject-introspection-0.9.3-1.fc14, nautilus-sendto-2.31.6-3.fc14, seahorse-plugins-2.30.1-3.fc14, totem-2.31.6-2.fc14, rhythmbox-0.13.0-5.fc14, sound-juicer-2.31.6-1.fc14, file-roller-2.31.90-1.fc14, yelp-2.30.1-4.fc14, gnome-media-2.31.6-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Joachim Backes 2010-08-19 01:36:50 EDT
Works for me.

Note You need to log in before you can comment on or make changes to this bug.