Bug 62224 - sun java 1.4 sdk fails due to libc problem
sun java 1.4 sdk fails due to libc problem
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: glibc (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-28 10:35 EST by Brian G. Anderson
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 10:35:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2002-03-28 10:35:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020310

Description of problem:
When I try and run java I now get the following message:
Error occurred during initialization of VM
Unable to load native library:
/usr/local/development/j2sdk1.4.0/jre/lib/i386/libjava.so: symbol
__libc_waitpid, verion GLIB_2.0 not defined in file libc.so.6 with link time
reference

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.intall java sdk 1.4
2.type java -version
3.
	

Actual Results:  error message above

Expected Results:  message with java version info

Additional info:
Comment 1 Jakub Jelinek 2002-03-28 10:43:09 EST
Nope, sun JDK 1.4 fails due to using glibc internal interface it shouldn't.
Either upgrade to JDK 1.4.1 which should have this fixed, or upgrade
glibc to 2.2.5-29 (e.g. from rawhide) where this is temporarily exported
for now.

Note You need to log in before you can comment on or make changes to this bug.