Bug 62225 - Noun 'practice' missing from aspell dicts.
Noun 'practice' missing from aspell dicts.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: aspell-en (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2002-03-28 10:49 EST by David Woodhouse
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-30 10:10:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2002-03-28 10:49:19 EST
The noun 'practice' isn't in the en_GB dictionary. I haven't checked the en_US
one but it's probably not in there either.

Strangely, /usr/share/dict/words has the noun but not the verb 'practise'.
Comment 1 Trond Eivind Glomsrxd 2002-03-28 10:56:13 EST
It's in the American list, not English (common) or British. Since it's specified
as only correct for one of them, I'll go with that :)
Comment 2 David Woodhouse 2002-03-28 11:07:56 EST
Both practise and practice are used in British English (like advise/advice).
I thought en_US was the same, hence they should both be in the common list.
Comment 3 David Woodhouse 2003-01-27 07:08:15 EST
The noun 'practice' is still missing from the en_GB dictionary. Bugzilla doesn't
seem to want to let me refile against aspell-en-gb though.
Comment 4 Eido Inoue 2003-02-20 13:09:59 EST
aspell will be upgraded in the next release
Comment 5 David Woodhouse 2004-05-08 15:18:28 EDT
evolution still doesn't like the word 'practice'
Comment 6 Colin Charles 2004-06-30 20:38:10 EDT
Evolution is still complaining. When using en_US, practice works,
while practise is a spelling error. When using en_GB, practice is a
spelling error, while practise works. Relevant packages are:
aspell-0.50.3-19.1
aspell-en-0.51-7.1

From rawhide...
Comment 7 Eido Inoue 2004-08-23 17:31:55 EDT
I'm going to put this as WONTFIX-- while British English may allow
both as "correct", the locale is used in aspell to get the most common
spellings, not all legal spellings. Users with specific needs can
always customize (or is it customise? :) their user dicts.

besides, if i added the alternate spellings, i'd probably just gets
loads of bug reports indicating that "advice" was in _GB, and vice versa.
Comment 8 David Woodhouse 2004-08-23 18:58:56 EDT
It's not a case of alternative spellings -- 'advice' is the noun,
'advise' is the verb. In that case they're even pronounced
differently. In fact in that case, both are indeed in the dictionary.

Many words are similar -- license/licence being an example which is
only true in en_GB. Again, both forms are in the en_GB dictionary. 

It's practise/practice which is the exception -- it is not acceptable
for the noun 'practice' to be absent, any more than it would be
acceptable for 'advice' or 'licence' to be absent. Please fix.
Comment 9 Eido Inoue 2004-08-23 19:07:19 EDT
Why not just set the locale/lang to "en" so you get both? (via
--lang=en-only etc)

(Using file /usr/lib/aspell/en-only.rws... has both advise and advice)
Comment 10 Mike A. Harris 2004-08-23 22:43:54 EDT
Does aspell have an upstream?
Comment 11 David Woodhouse 2006-02-27 10:19:04 EST
After upgrading to rawhide (FC5t3), Evolution still doesn't like the word
'practice'.
Comment 12 Ivana Varekova 2006-03-03 06:00:36 EST
This problem is fixed in aspell-en-6.0-2.
Comment 13 David Woodhouse 2007-07-06 15:20:05 EDT
Still not fixed in F7.
Comment 14 Ivana Varekova 2007-07-09 08:48:56 EDT
I try to reproduce the problem but I was not succesful aspell-en-6.0-7.fc7
accepts 'practice' as an English word. Which version of aspell-en do you have?
Comment 15 David Woodhouse 2007-07-10 03:06:48 EDT
It seems to accept it in en_US mode but not en_GB. Were you testing en_GB?
Comment 16 Ivana Varekova 2007-08-30 10:10:58 EDT
Fixed in aspell-en-6.0-8.fc8.

Note You need to log in before you can comment on or make changes to this bug.