Bug 62231 - memprof rpm missing from server install
memprof rpm missing from server install
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: memprof (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-28 12:03 EST by Christopher Holmes
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 12:03:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christopher Holmes 2002-03-28 12:03:09 EST
Description of Problem:

  memprof rpm missing from server install

Version-Release number of selected component (if applicable):

  memprof-0.4.1-5

How Reproducible:

  always

Steps to Reproduce:
1. install RedHat7.2 beta for alpha as server, selecting all packages
2. rpm -qa | grep memprof
3. 

Actual Results:

  no memprof rpm

Expected Results:

  memprof rpm shows up

Additional Information:
	expected results achieved on RedHat7.2 Intel server install
Comment 1 Owen Taylor 2002-03-28 12:10:36 EST
MemProf, to my knowledge is simply impossible to port to the Alpha
architecture due to the stack layout and calling conventions. 

(MemProf works by doing a complete backtrace for every malloc()
or free. Backtraces on Alpha require searches to find the stack location,
so the result would be something probably hundreds of times slower
on Alpha than on i386, making it entirely useless.)

Note You need to log in before you can comment on or make changes to this bug.