Bug 62233 - evolution apply filters action menu item does not work
evolution apply filters action menu item does not work
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: evolution (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-28 12:28 EST by Jef Spaleta
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 00:25:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2002-03-28 12:28:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020311

Description of problem:
the apply filters in the action menu is greyed out and does not work...
also apply filters on incoming mail is no longer working in 1.0.3
It worked in 1.0.2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.choose a folder
2. Edit menu.... select all
3. Actions menu...apply filters  the option is greyed out
	
4. right click on a selected message,,,and apply filters is usable and works
correctly

Actual Results:  Cant use apply filters from the action menu
Filters not applied to incoming mail..even though the option is selected in the
Accounts Receiving mail options..related problem?

Expected Results:  Action menu..apply filters should be activated when messages
are hilighted for selection

Filters should automagically be applied when the option to apply filters on
incoming mail is selected in the mail acount receiving mail options

Additional info:
Comment 1 Nathan G. Grennan 2002-04-01 02:05:39 EST
I am running evolution-1.0.3-1 and I don't see this problem. I tried Select all
and checking the actions mention to see if apply filters was greyed out in
incoming and a imap folder. It worked just fine in both. Is the account setup as
pop3?
Comment 2 Jeremy Katz 2002-04-01 10:49:50 EST
I also can't reproduce this -- what type of mail spool is this on?
Comment 3 Jef Spaleta 2002-04-01 12:46:54 EST
No this are all imap servers.

I think this is is related to a more general problem
If i have several imap folders and I enter a folder without explicitly selecting
a message to read...many options become greyed out...even when i switch back to
a folder where i have a message selected.

To prevent this I have to switch to another folder and select a message to view.
It's like evo isnt keeping track of the toolbar scope when switching between
folders.  For a new selected folder without a selected message...the greyd out
buttons make sense.  But when I switch back to a folder where a message has been
actively selected, the buttons stayed greyed out.

Several buttons are affected...trash...apply filters  are the obvious examples
becuase I've run into both of these now
Comment 4 Jeremy Katz 2002-06-04 00:24:57 EDT
There was a bonobo race condition which caused something like this at one point
-- what version of bonobo do you have installed?
Comment 5 Jeremy Katz 2002-08-11 15:48:31 EDT
Closing due to lack of activity

Note You need to log in before you can comment on or make changes to this bug.