This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 62236 - kickstart reads but doesn't use ks.cfg from pxeboot nfs install
kickstart reads but doesn't use ks.cfg from pxeboot nfs install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-28 13:25 EST by Vince Skahan
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-05 07:58:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
config files to set up kickstart scenario (830 bytes, text/plain)
2002-03-28 14:03 EST, Vince Skahan
no flags Details

  None (edit)
Description Vince Skahan 2002-03-28 13:25:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I'm trying to develop a totally hands-off network-based kickstart environment 
for systems that have the ability to PXE boot off of their eth1 network card.   
I've been unable to make it totally hands-off, I need to hit <return> at the 
boot prompt in order to have the installer read (and use) the nfs-supplied 
ks.cfg file. If you let the syslinux boot prompt timeout occur rather than 
hitting return at the boot: prompt, the ks.cfg file is not read from the nfs-
mounted directory, it instead reads a ks.cfg (if present) from /tmp 'within' 
the initrd file, then does 'not' use the file at all.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. set up tftp to boot the pxelinux.0 file from syslinux-1.67 (current version) 
or pxelinux.bin from syslinux-1.52 (what's in rh72)
2. configure a simple /tftpboot/pxelinux.cfg/default config file with a timeout 
specified
3. configure appropriately make rh72 available via nfs
4. put a minimal ks.cfg file within the nfs-exported rh72 tree
5. enable  dhcpd and nfs services on the server
6. boot the system you want to kickstart
7. let the boot prompt timeout, it autoboots and starts to install, anaconda 
doesn't process the ks.cfg file at all
8. if you hit 'return' in step 7, it works just fine
	

Actual Results:  If you h
Comment 1 Vince Skahan 2002-03-28 14:03:27 EST
Created attachment 51204 [details]
config files to set up kickstart scenario
Comment 2 Falko Sonne 2002-04-05 07:58:22 EST
In your pxelinux.cfg/default you have to add a ":" after the IP-Address of the 
NFS server.

In my configuration it looks like this:

label linux
	kernel vmlinuz
	append initrd=initrd.img 
ks=nfs:192.168.0.102:/pub/RedHat/kickstart/ks.cfg

Without the ":" I get the same error messages like you.

And if you supply a path name rather than a file name, Anaconda looks for a 
file named: <IP-address>-kickstart in the specified directory. (That's what I'm 
using, because you can use some predefined kickstart files and simply create 
symbolic links for the new machines: 192.168.0.111-kickstart -> kickstart-gnome

Good luck!
Comment 3 Jeremy Katz 2002-04-05 14:55:32 EST
What he said :-)
Comment 4 Vince Skahan 2002-04-05 17:50:59 EST
actually, I'd like it reopened please.  My attachment had the colon removed while saving it, it's there as indicated in the real config file (bad cut/paste 
job on my part).

In the 'more information' category, I verified this afternoon that if I set PROMPT to zero then it does the right thing, it's just if prompt is set non-zero 
that the file isn't used.

Note You need to log in before you can comment on or make changes to this bug.