Bug 622450 - kpackagekit shows warning about reboot while system update still in progress
kpackagekit shows warning about reboot while system update still in progress
Status: CLOSED DUPLICATE of bug 513755
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-09 08:24 EDT by Pentarh Udi
Modified: 2010-08-09 10:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-09 10:34:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot 1 (118.94 KB, image/jpeg)
2010-08-09 08:24 EDT, Pentarh Udi
no flags Details
screenshot 2 (145.97 KB, image/jpeg)
2010-08-09 08:25 EDT, Pentarh Udi
no flags Details

  None (edit)
Description Pentarh Udi 2010-08-09 08:24:26 EDT
Created attachment 437580 [details]
screenshot 1

Description of problem:
When updates of critical packages (like glibc or kernel) are available, and I try to install those ones via KpackageKit (KDE), kpackagekit shows me warning message "system updated, system reboot required" while update still in progress.

I think this message should appear after successful update, but not in a stage of downloading packages.

I see this bug since  I installed Fedora 11. Fedora 13 still there, 12 also.

Version-Release number of selected component (if applicable):
kpackagekit-0.6.0-2.fc13.x86_64
kernel 2.6.33.6-147.fc13.x86_64
kdebase-4.4.5-1.fc13.x86_64
yum-3.2.28-1.fc13.noarch
rpm-4.8.1-2.fc13.x86_64

How reproducible:
middle-hard, because you need to wait for critical updates are available to see this bug.

Steps to Reproduce:
1. Wait while updates for packages which need to reboot or re-login after update became available.
2. Run Kpackagekit and go to Software updates section. (screenshot 1)
3. Press "Select All updates", Press "Apply updates"
4. When Kpackagekit starts to download packages, you will see KDE warning:
 System update has been completed
 A restart is required.
 Buttons: Restart, Not now
 (screenshot 2)
  
Actual results:
The KDE warning at point 4 is shown when system update has just started and in progress.

Expected results:
The KDE warning at point 4 is shown when system update has been completed without any errors.


Additional info:

See screenshots.
Comment 1 Pentarh Udi 2010-08-09 08:25:05 EDT
Created attachment 437581 [details]
screenshot 2
Comment 2 Kevin Kofler 2010-08-09 10:34:10 EDT

*** This bug has been marked as a duplicate of bug 513755 ***

Note You need to log in before you can comment on or make changes to this bug.