Bug 622486 - make sure all plugins name maps in list-o-maps the same
make sure all plugins name maps in list-o-maps the same
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Filip Drabek
Corey Welton
:
Depends On:
Blocks: jon241-bugs jon30-bugs
  Show dependency treegraph
 
Reported: 2010-08-09 09:56 EDT by John Mazzitelli
Modified: 2011-05-23 21:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 21:11:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2010-08-09 09:56:48 EDT
make sure all plugins name maps in list-o-maps the same to avoid bug #610859

side question: do they really need to be the same? Why is PropertyList.add checking this and throwing an exception when the maps don't match?

See the code that throws:

Caused by java.lang.IllegalStateException with message: "All properties in a
PropertyList must have the same name."
Comment 1 Filip Drabek 2010-11-24 18:11:30 EST
I have commited Jay's fix for bug 610859 to release-3.0 branch.
I have checked all plugins and I have not found any similar problem with list of maps.
Comment 2 Corey Welton 2011-05-23 21:11:30 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 3 Corey Welton 2011-05-23 21:11:30 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.