Bug 622494 - can't set zone & time in one step
can't set zone & time in one step
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-date (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Synacek
Jakub Prokes
: FastFix, Patch
Depends On: 651882
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-09 10:16 EDT by Karel Volný
Modified: 2017-03-21 07:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 651882 (view as bug list)
Environment:
Last Closed: 2017-03-21 07:37:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0765 normal SHIPPED_LIVE system-config-date bug fix update 2017-03-21 08:47:26 EDT

  None (edit)
Description Karel Volný 2010-08-09 10:16:28 EDT
Description of problem:
I wanted to set the time zone on a server to my local time zone & change the time manually. After doing this, the time was shifted by the previous-current zone difference.

Version-Release number of selected component (if applicable):
system-config-date-1.9.59-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. system-config-date
2. at Time Zone tab, select the desired new time zone (different from the current)
3. at Date and Time tab, uncheck "Synchronize date and time over the network"
4. set the desired date & time
5. click OK
  
Actual results:
the system time is not the same as set, it is shifted by the difference between the old and new time zone - you have to set the zone at first, then close the tool by clicking okay, then run it again and set the time

Expected results:
the system time corresponds to what was set according to the new time zone, the setting can be done in one system-config-date run

Additional info:
Comment 2 RHEL Product and Program Management 2010-08-09 10:48:09 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 Nils Philippsen 2010-11-10 09:57:19 EST
Karel, please check out the code from git:

git://git.fedorahosted.org/system-config-date.git

Then verify that my fix -- setting the time zone before date/time -- helps your issue. Thanks.
Comment 6 RHEL Product and Program Management 2011-07-05 19:44:05 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 7 Karel Volný 2012-03-01 10:03:24 EST
(In reply to comment #5)
> Karel, please check out the code from git:
> 
> git://git.fedorahosted.org/system-config-date.git
> 
> Then verify that my fix -- setting the time zone before date/time -- helps your
> issue. Thanks.

yes, using the version from git, I get the time set correctly in one step

... sorry for very late reply ;-)
Comment 8 Nils Philippsen 2012-03-02 03:25:36 EST
Proposed patch in upstream git:

commit beadafcccaeb5c9b3437a5dd8a1a207981ef3f88
Author:     Nils Philippsen <nils@redhat.com>
AuthorDate: Wed Nov 10 15:46:58 2010 +0100
Commit:     Nils Philippsen <nils@redhat.com>
CommitDate: Wed Nov 10 15:46:58 2010 +0100

    set time zone before date/time (#651882)
Comment 9 RHEL Product and Program Management 2012-09-07 01:00:09 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 22 errata-xmlrpc 2017-03-21 07:37:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0765.html

Note You need to log in before you can comment on or make changes to this bug.