Bug 622519 - SELinux is preventing /usr/bin/python "getattr" access on /usr/include/python2.7/pyconfig-64.h.
SELinux is preventing /usr/bin/python "getattr" access on /usr/include/p...
Status: CLOSED DUPLICATE of bug 622518
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:0d521bb68ec...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-09 11:41 EDT by Eric Blake
Modified: 2010-08-10 14:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 14:02:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Blake 2010-08-09 11:41:30 EDT
Summary:

SELinux is preventing /usr/bin/python "getattr" access on
/usr/include/python2.7/pyconfig-64.h.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by system-config-k. It is not expected that this
access is required by system-config-k and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:kdumpgui_t:s0-s0:c0.c1023
Target Context                system_u:object_r:usr_t:s0
Target Objects                /usr/include/python2.7/pyconfig-64.h [ file ]
Source                        system-config-k
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.7-7.fc15
Target RPM Packages           python-2.7-7.fc15
Policy RPM                    selinux-policy-3.8.8-8.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.36-0.0.rc0.git1.fc15.x86_64 #1 SMP
                              Wed Aug 4 16:26:35 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Mon 09 Aug 2010 09:40:06 AM MDT
Last Seen                     Mon 09 Aug 2010 09:40:06 AM MDT
Local ID                      e07abf1c-1e84-4c2d-8361-e179b220fbf6
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1281368406.832:35661): avc:  denied  { getattr } for  pid=2663 comm="system-config-k" path="/usr/include/python2.7/pyconfig-64.h" dev=dm-1 ino=408479 scontext=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 tcontext=system_u:object_r:usr_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1281368406.832:35661): arch=c000003e syscall=5 success=yes exit=0 a0=5 a1=7fff5bc65780 a2=7fff5bc65780 a3=0 items=0 ppid=2662 pid=2663 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="system-config-k" exe="/usr/bin/python" subj=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,system-config-k,kdumpgui_t,usr_t,file,getattr
audit2allow suggests:

#============= kdumpgui_t ==============
allow kdumpgui_t usr_t:file getattr;
Comment 1 Miroslav Grepl 2010-08-10 14:02:05 EDT

*** This bug has been marked as a duplicate of bug 622518 ***

Note You need to log in before you can comment on or make changes to this bug.