Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 622590 - Installer stops when getting to retrieving repomd.xml during netinstall
Installer stops when getting to retrieving repomd.xml during netinstall
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-09 16:30 EDT by Anders
Modified: 2010-08-11 12:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 12:43:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Archive with logs. (37.95 KB, application/x-gzip)
2010-08-09 16:42 EDT, Anders
no flags Details

  None (edit)
Description Anders 2010-08-09 16:30:49 EDT
Description of problem:
Parallels Desktop (5.0.9370 - latest released), I try to install a F13 i386 netinst. Have obtained the .iso via jigdo, it checks out okay and if I burn it to CD, I can install physical machines with it.
I elect during installation to use the main entry, tab, add "vga=ask text debug", proceed with installation. I mostly answer everything with defaults, but keymap is Dvorak and TZ is Europe/Stockholm. I use all of the disk, fresh install, commit to disk. Set up network (have tried both routed and bridged, no difference) works fine, I can ping external addresses from Alt-F2 as name resolution is working fine, I can even scp data off the install system, so that part works.
However, the installer here stops, complaining that it can not pull the repomd.xml for the 'fedora' repo. (I've tried this with the GUI installer as well, stops at exactly the same place.)

Version-Release number of selected component (if applicable):
04:10:03,237 INFO loader: anaconda version 13.42 on i386 starting

How reproducible:
100%

Steps to Reproduce:
1. Download F13 i386 netinst ISO
2. Set up to install a VM in Parallels, but don't pick any of the "automated installs" settings
3. Step through the prompts until it has committed disk choices to disk
4. Watch it stop at fetching repomd.xml for 'fedora', giving you only the options to quit, retry or edit repo settings (which don't work in the text mode).
  
Actual results:
Installation of F13 not possible

Expected results:
Installation of F13 completes, and I can use it as any other VM.

Additional info:
I'll attach a tar.gz containing the various files from /tmp in the installer that bcl in #anaconda suggested I provide.
Comment 1 Anders 2010-08-09 16:42:07 EDT
Created attachment 437702 [details]
Archive with logs.
Comment 2 Anders 2010-08-09 18:03:16 EDT
Tried with F12 i386 netinst - same problem at exactly the same spot in the installer. Tried F11 i386 netinst, and that's just completed installing (so no problem there, it's booting fine). I'll next try with F12 and F13 full DVD's but they need to finish jigdo'ing first.
Comment 3 Chris Lumens 2010-08-11 10:07:33 EDT
Can you post the exact error message you are seeing so I can narrow down where in the code it's happening?  Perhaps I can create an updates image that'll be more useful in debugging based on that.
Comment 4 Anders 2010-08-11 12:16:49 EDT
Hi there,

The requester I was getting was basically saying that it could not obtain the repomd.xml for the fedora repository. I've just set up to reproduce it and capture a screenshot for you, but I can no longer reproduce this error (it's actually installing at the moment) although when I spoke with you and bcl on #anaconda, it was 100% consistent (and I was trying a fair few times).

Based on what I'm currently seeing, I'm hypothesizing that the favoured mirror that the installer picked had a bad repomd.xml or something. No log would actually show this was the case though, so I can't prove it.

I'll suggest to NOTABUG this one due to it no longer being reproducible. If I come across it again, I'll reopen this bug and provide the data.

Thanks for your patience,

/Anders
Comment 5 Chris Lumens 2010-08-11 12:43:04 EDT
That works.  Thanks for the reply.

Note You need to log in before you can comment on or make changes to this bug.