Bug 622597 - PHP strtotime fails on dates before 1900
Summary: PHP strtotime fails on dates before 1900
Status: CLOSED DUPLICATE of bug 607453
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: php   
(Show other bugs)
Version: 5.5
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Joe Orton
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-09 21:13 UTC by icarolan27
Modified: 2011-12-16 15:01 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-16 15:01:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description icarolan27 2010-08-09 21:13:31 UTC
Description of problem:

strtotime should provide a timestamp given a date string. In a 64bit OS this timestamp should not be limited to the value of a 32bit interger.

Version-Release number of selected component (if applicable):
5.1.6

How reproducible:
Always.

Steps to Reproduce:
1. Provide a date before to 1900 to strtotime()
  
Actual results:
Fails and returns FALSE.

Expected results:
Provides a negative timestamp not limited by a 32bit interger.

Additional info:
Working on Slackware64 13.1

Comment 1 Joe Orton 2011-12-16 15:01:04 UTC

*** This bug has been marked as a duplicate of bug 607453 ***


Note You need to log in before you can comment on or make changes to this bug.