Bug 622617 - Not working with subdomains
Not working with subdomains
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind-dyndb-ldap (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 658286
  Show dependency treegraph
 
Reported: 2010-08-09 19:01 EDT by Michal Bruncko
Modified: 2013-04-30 19:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: bind-dyndb-ldap-0.1.0-0.15.b.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 658286 (view as bug list)
Environment:
Last Closed: 2011-01-03 14:59:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DNS LDIF Example (2.48 KB, text/plain)
2010-08-09 19:01 EDT, Michal Bruncko
no flags Details

  None (edit)
Description Michal Bruncko 2010-08-09 19:01:54 EDT
Created attachment 437726 [details]
DNS LDIF Example

Description of problem:
Latest version of bind-dyndb-ldap does not work with subdomains that are configured in ldap. Main domain (i.e. example.com) is loaded fine:
------------------------------------------------
querying 'idnsName=example.com,ou=Dynamic,ou=DNS,ou=Sluzby,dc=example,dc=com' with '(objectClass=idnsRecord)'
entry count: 1
------------------------------------------------

but all subdomains are loaded with errors:
------------------------------------------------
querying 'idnsName=srv, idnsName=example.com,ou=Dynamic,ou=DNS,ou=Sluzby,dc=example,dc=com' with '(objectClass=idnsRecord)'
entry count: 1
zone srv.example.com/IN: has 0 SOA records
zone srv.example.com/IN: not loaded due to errors.
------------------------------------------------

Complete example is in attachment. Subdomain (srv.example.com) is configured as record (idnsName=srv) in main domain (example.com) with NS records and also is placed in DNS container (like main domain) with SOA, NS records in object and classic zone records as subtree. 

Version-Release number of selected component (if applicable):
bind-dyndb-ldap-0.1.0-0.9.a1.20091210git.fc13.x86_64
bind-9.7.1-2.P2.fc13.x86_64
openldap-2.4.21-9.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. import attachment
2. configure ldap section in named.conf to correct LDAP subtree
3. restart named
4. try to query pdc.srv.example.com
  
Actual results:
return code of query is SERVFAIL

Expected results:
return code of query should be NOERROR


query of record ares.example.com will succeeded.

Additional info:
With version bind-dyndb-ldap-0.1.0-0.5.a1.fc13.x86_64 (recompliled from fc12) everything works fine:
zone srv.example.com/IN: sending notifies (serial 2009083001)

I do no if the DNS structure in LDAP was changed, bud I could not find any info about changes. I am using latest schema distributed with last version of bind-dyndb-ldap. Subtree example is not included with package and I have configured it like with file backend in named.
Comment 1 Fedora Admin XMLRPC Client 2010-12-15 10:41:32 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Update System 2010-12-15 12:42:17 EST
bind-dyndb-ldap-0.1.0-0.15.b.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/bind-dyndb-ldap-0.1.0-0.15.b.fc14
Comment 3 Fedora Update System 2010-12-15 12:42:28 EST
bind-dyndb-ldap-0.1.0-0.11.a1.20091210git.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/bind-dyndb-ldap-0.1.0-0.11.a1.20091210git.fc13
Comment 4 Fedora Update System 2010-12-17 03:30:31 EST
bind-dyndb-ldap-0.1.0-0.15.b.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bind-dyndb-ldap'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/bind-dyndb-ldap-0.1.0-0.15.b.fc14
Comment 5 Michal Bruncko 2010-12-19 10:29:06 EST
worked! thanks
Comment 6 Fedora Update System 2011-01-03 14:59:11 EST
bind-dyndb-ldap-0.1.0-0.11.a1.20091210git.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2011-01-03 15:08:06 EST
bind-dyndb-ldap-0.1.0-0.15.b.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.