Bug 622661 - virt-install should error if --extra-args specified without --location
Summary: virt-install should error if --extra-args specified without --location
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords: RHELNAK
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-10 05:19 UTC by weizhang
Modified: 2011-05-19 13:45 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previous versions of virt-install would not display an error message if --extra-args is specified without --location. This fix displays an error message informing the user of the correct usage.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 13:45:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0636 normal SHIPPED_LIVE python-virtinst bug fix and enhancement update 2011-05-18 17:55:48 UTC

Description weizhang 2010-08-10 05:19:40 UTC
Description of problem:
When install a guest with cdrom/iso and with 
--nographics --extra-args "console=ttyS0,115200"
it can not continue. The console list:

Starting install...
Allocating 'text.img'                                                                | 5.0 GB     00:00     
Creating domain...                                                                   |    0 B     00:00     
Connected to domain text
Escape character is ^]

and it can not continue


Version-Release number of selected component (if applicable):

libvirt-0.8.1-21.el6.x86_64
python-virtinst-0.500.3-7.el6.noarch
qemu-kvm-0.12.1.2-2.108.el6.x86_64
kernel 2.6.32-59.1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.virt-install -n text -r 1024 -f /var/lib/libvirt/images/text.img -s 5 -c /dev/cdrom --nographics --extra-args "console=ttyS0,115200"
2.
3.
  
Actual results:
can not continue

Expected results:
continue to install until finish

Additional info:

Comment 2 RHEL Product and Program Management 2010-08-10 05:38:47 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 3 Cole Robinson 2010-08-10 11:16:27 UTC
--extra-args doesn't work with CDROM installs, as mentioned in the docs. We should probably raise an error in this case.

Comment 4 Daniel Berrange 2010-08-10 11:26:46 UTC
Yep, raising an error would be very good - people are constantly hitting this limitation and filing unnecessary bugs.

Comment 5 weizhang 2010-08-11 01:48:27 UTC
with no --extra-args "console=ttyS0,115200" the result is same. So I think the problem is not come from --extra-args

Comment 6 Cole Robinson 2010-12-01 16:31:13 UTC
weizhang, that extra-args bit is required to get text console during install with KVM. however, extra-args only works with --location installs. so basically, there is no way via command line options to get a serial console with a CDROM install, you have to hack up the iso.

Comment 7 Cole Robinson 2011-01-14 22:10:22 UTC
Fix built in python-virtinst-0.500.5-1.el6

Comment 9 koka xiong 2011-01-20 09:09:30 UTC
Verified with python-virtinst-0.500.5-1.el6 passed
1.virt-install -n text -r 1024 --disk path=/var/lib/libvirt/images/test1,size=1 -c /dev/cdrom --extra-args "console=ttyS0,115200"
2.It will output
ERROR    --extra-args only work if specified with --location.

3.virt-install -n text -r 1024 --disk path=/var/lib/libvirt/images/test1,size=1 -c /dev/cdrom --nographics --extra-args "console=ttyS0,115200"
4.It will output
ERROR    --extra-args only work if specified with --location.

Now it will give an error message about --extra-args usage
Verification is passed.

Comment 10 zhe peng 2011-04-15 10:19:36 UTC
verified this bug with:
Linux localhost.localdomain 2.6.32-130.el6.x86_64 #1 SMP Tue Apr 5 19:58:31 EDT
2011 x86_64 x86_64 x86_64 GNU/Linux

python-virtinst-0.500.5-3.el6.noarch
libvirt-0.8.7-17.el6.x86_64

passed.

Comment 12 Michael Hideo 2011-05-15 22:26:34 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
* Previous versions of virt-install would not display an error message if --extra-args is specified without --location. This fix displays an error message informing the user of the correct usage. (BZ#622661)

Comment 13 Michael Hideo 2011-05-16 21:43:12 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-* Previous versions of virt-install would not display an error message if --extra-args is specified without --location. This fix displays an error message informing the user of the correct usage. (BZ#622661)+Previous versions of virt-install would not display an error message if --extra-args is specified without --location. This fix displays an error message informing the user of the correct usage.

Comment 14 errata-xmlrpc 2011-05-19 13:45:47 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0636.html


Note You need to log in before you can comment on or make changes to this bug.