Bug 622662 - SELinux empêche l'accès en "search" à /usr/libexec/polkit-1/polkitd on /var/run/ConsoleK
SELinux empêche l'accès en "search" à /usr/libexec/polkit-1/polkitd on /...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
14
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:0b505f70670...
:
Depends On:
Blocks: F14Target
  Show dependency treegraph
 
Reported: 2010-08-10 01:31 EDT by Nicolas Mailhot
Modified: 2010-11-26 20:49 EST (History)
13 users (show)

See Also:
Fixed In Version: selinux-policy-3.8.8-14.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 21:50:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2010-08-10 01:31:18 EDT
Résumé:

SELinux empêche l'accès en "search" à /usr/libexec/polkit-1/polkitd on
/var/run/ConsoleK

Description détaillée:

[SELinux est en mode permissif. Cet accès n'a pas été refusé.]

SELinux a refusé l'accès demandé par polkitd. Il n'est pas prévu que cet
accès soit requis par polkitd et cet accès peut signaler une tentative
d'intrusion. Il est également possible que cette version ou cette configuration
spécifique de l'application provoque cette demande d'accès supplémenta

Autoriser l'accès:

Vous pouvez créer un module de stratégie locale pour autoriser cet accès -
lisez la FAQ (http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Merci de
remplir un rapport de bogue.

Informations complémentaires:

Contexte source               system_u:system_r:policykit_t:s0
Contexte cible                system_u:object_r:consolekit_var_run_t:s0
Objets du contexte            /var/run/ConsoleKit [ dir ]
source                        polkitd
Chemin de la source           /usr/libexec/polkit-1/polkitd
Port                          <Inconnu>
Hôte                         (supprimé)
Paquetages RPM source         polkit-0.97-1.fc14
Paquetages RPM cible          ConsoleKit-0.4.1-5.fc13
Politique RPM                 selinux-policy-3.8.8-11.fc14
Selinux activé               True
Type de politique             targeted
Mode strict                   Permissive
Nom du plugin                 catchall
Nom de l'hôte                (supprimé)
Plateforme                    Linux (supprimé) 2.6.35.1-5.rc1.fc14.x86_64 #1 SMP
                              Tue Aug 10 01:51:34 UTC 2010 x86_64 x86_64
Compteur d'alertes            2
Première alerte              mar. 10 août 2010 07:26:38 CEST
Dernière alerte              mar. 10 août 2010 07:30:22 CEST
ID local                      20062505-ab76-48e7-b318-bbc0772d78fc
Numéros des lignes           

Messages d'audit bruts        

node=(supprimé) type=AVC msg=audit(1281418222.4:116): avc:  denied  { search } for  pid=1297 comm="polkitd" name="ConsoleKit" dev=dm-1 ino=27000 scontext=system_u:system_r:policykit_t:s0 tcontext=system_u:object_r:consolekit_var_run_t:s0 tclass=dir

node=(supprimé) type=SYSCALL msg=audit(1281418222.4:116): arch=c000003e syscall=21 success=yes exit=0 a0=20c62c0 a1=0 a2=3000e182c0 a3=7fffe52f17d0 items=0 ppid=1 pid=1297 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="polkitd" exe="/usr/libexec/polkit-1/polkitd" subj=system_u:system_r:policykit_t:s0 key=(null)



Hash String generated from  catchall,polkitd,policykit_t,consolekit_var_run_t,dir,search
audit2allow suggests:

#============= policykit_t ==============
allow policykit_t consolekit_var_run_t:dir search;
Comment 1 David Zeuthen 2010-08-10 11:59:30 EDT
Yep, I've been getting the same AVCs on the development code here. The change is legitimate - it's there in 0.97 because polkitd now reads (some) information directly from /var/run/ConsoleKit/database instead of doing it through D-Bus (as it is much more efficient that way). Dan, please allow polkitd to do this. Thanks.
Comment 2 Daniel Walsh 2010-08-11 08:57:38 EDT
You can add these rules for now using

# grep avc /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Fixed in selinux-policy-3.8.8-12.fc14
Comment 3 Jiri Pirko 2010-08-12 03:22:20 EDT
I'm hitting the same on rawhide. I have selinux-policy-3.8.8-10.fc14.
Comment 4 Jóhann B. Guðmundsson 2010-08-12 03:34:22 EDT
Dan it seems you forgot to push selinux-policy-3.8.8-12.fc14 to updates-testing needed so we can give you karma and get this all the way down to updates
Comment 5 Daniel Walsh 2010-08-13 14:26:57 EDT
I will end of today.
Comment 6 Fedora Update System 2010-08-13 16:29:28 EDT
selinux-policy-3.8.8-14.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/selinux-policy-3.8.8-14.fc14
Comment 7 Fedora Update System 2010-08-23 21:49:00 EDT
selinux-policy-3.8.8-14.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.