Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 622705 - [kdump]Waiting for 1 sda-like device(s)
[kdump]Waiting for 1 sda-like device(s)
Status: CLOSED DUPLICATE of bug 630060
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Cong Wang
Red Hat Kernel QE team
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 04:12 EDT by Chao Ye
Modified: 2013-09-29 22:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-06 06:51:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full console log of i686. (36.62 KB, text/plain)
2010-08-10 04:13 EDT, Chao Ye
no flags Details
Full console log of x86_64. (39.02 KB, text/plain)
2010-08-10 04:14 EDT, Chao Ye
no flags Details
Another console log of i686, something different with first one. (36.70 KB, text/plain)
2010-08-10 04:15 EDT, Chao Ye
no flags Details

  None (edit)
Description Chao Ye 2010-08-10 04:12:21 EDT
Description of problem:
I find kexec-tools doesn't works on hp-dl380g6-01.rhts.eng.bos.redhat.com.
......
Console: switching to colour frame buffer device 128x48
fb0: radeondrmfb frame buffer device
drm: registered panic notifier
Slow work thread pool: Starting up
Slow work thread pool: Ready
[drm] Initialized radeon 2.1.0 20080528 for 0000:01:03.0 on minor 0
Waiting for required block device discovery
Waiting for 1 sda-like device(s)...^   <=====Hang here.

Version-Release number of selected component (if applicable):
    kernel-2.6.32.59
    kexec-tools-133.el6

How reproducible:
Always

Steps to Reproduce:
1.Install RHEL6 on hp-dl380g6-01.rhts.eng.bos.redhat.com
2.Set up kdump
3.Trigger a crash
  
Actual results:
System hang

Expected results:
System works fine

Additional info:
I tried both x86_64 and i686 on this machine, they all didn't work. But the console log shows some different.
This is i686:
=========================================
......
Waiting for required block device discovery
Waiting for 1 sda-like device(s)...^

And, this is x86_64:
=========================================
......
Waiting for required block device discovery
Waiting for 1 sda-like device(s)...Uhhuh. NMI received for unknown reason b1 on CPU 0.
You have some hardware problem, likely on the PCI bus.
Dazed and confused, but trying to continue
DRHD: handling fault status reg 2
INTR-REMAP: Request device [[02:00.0] fault index 37
INTR-REMAP:[fault reason 34] Present field in the IRTE entry is clear
DRHD: handling fault status reg 102
INTR-REMAP: Request device [[02:00.0] fault index 35
INTR-REMAP:[fault reason 34] Present field in the IRTE entry is clear
DRHD: handling fault status reg 202
INTR-REMAP: Request device [[02:00.0] fault index 33
INTR-REMAP:[fault reason 34] Present field in the IRTE entry is clear
Comment 1 Chao Ye 2010-08-10 04:13:48 EDT
Created attachment 437806 [details]
Full console log of i686.
Comment 2 Chao Ye 2010-08-10 04:14:25 EDT
Created attachment 437807 [details]
Full console log of x86_64.
Comment 3 Chao Ye 2010-08-10 04:15:49 EDT
Created attachment 437808 [details]
Another console log of i686, something different with first one.
Comment 5 RHEL Product and Program Management 2010-08-10 04:38:33 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 6 RHEL Product and Program Management 2010-08-18 17:24:47 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Red Hat Enterprise Linux. Unfortunately, we
are unable to address this request in the current release. Because we
are in the final stage of Red Hat Enterprise Linux 6 development, only
significant, release-blocking issues involving serious regressions and
data corruption can be considered.

If you believe this issue meets the release blocking criteria as
defined and communicated to you by your Red Hat Support representative,
please ask your representative to file this issue as a blocker for the
current release. Otherwise, ask that it be evaluated for inclusion in
the next minor release of Red Hat Enterprise Linux.
Comment 7 Tomas Henzl 2010-10-06 05:52:04 EDT
The hpsa driver doesn't work at the moment with kdump, see bz 630060

Note You need to log in before you can comment on or make changes to this bug.