Bug 622716 - [abrt] crash in fedora-packager-0.5.1.0-1.fc13: repo.py:116:__init__:InvalidGitRepositoryError: /home/tajidin/fedora-scm/itools
[abrt] crash in fedora-packager-0.5.1.0-1.fc13: repo.py:116:__init__:InvalidG...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-packager (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
abrt_hash:f7b8ccb5
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 04:51 EDT by Tajidin Abdullah
Modified: 2013-01-10 01:08 EST (History)
2 users (show)

See Also:
Fixed In Version: fedora-packager-0.5.1.2-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 01:37:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (780 bytes, text/plain)
2010-08-10 04:51 EDT, Tajidin Abdullah
no flags Details

  None (edit)
Description Tajidin Abdullah 2010-08-10 04:51:18 EDT
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/fedpkg import /home/tajidin/rpmbuild/SRPMS/itools-1.0-6.fc13.src.rpm
component: fedora-packager
executable: /usr/bin/fedpkg
kernel: 2.6.33.6-147.2.4.fc13.i686
package: fedora-packager-0.5.1.0-1.fc13
reason: repo.py:116:__init__:InvalidGitRepositoryError: /home/tajidin/fedora-scm/itools
release: Fedora release 13 (Goddard)

backtrace
-----
repo.py:116:__init__:InvalidGitRepositoryError: /home/tajidin/fedora-scm/itools

Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 959, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 465, in import_srpm
    uploadfiles = pyfedpkg.import_srpm(args.srpm, path=args.path)
  File "/usr/lib/python2.6/site-packages/pyfedpkg/__init__.py", line 395, in import_srpm
    repo = git.Repo(path)
  File "/usr/lib/python2.6/site-packages/git/repo.py", line 116, in __init__
    raise InvalidGitRepositoryError(epath)
InvalidGitRepositoryError: /home/tajidin/fedora-scm/itools

Local variables in innermost frame:
dummy: ''
self: <git.Repo "None">
curpath: '/'
epath: '/home/tajidin/fedora-scm/itools'
path: '/home/tajidin/fedora-scm/itools'
gitpath: '/.git'

How to reproduce
-----
1. Open a terminal and try to import the contents of SRPM into the scm
2. http://fedoraproject.org/wiki/PackageMaintainers/Join#Import_Your_Package
3.
Comment 1 Tajidin Abdullah 2010-08-10 04:51:20 EDT
Created attachment 437812 [details]
File: backtrace
Comment 2 Jesse Keating 2010-08-10 15:17:10 EDT
First I need to trap this error.

Second it seems that you tried to import into a directory that was not a clone of your module.  How did the "/home/tajidin/fedora-scm/itools" directory get created?
Comment 3 Tajidin Abdullah 2010-08-10 17:58:20 EDT
Perhaps this was user error oĊ„ me but i followed the instruction per this wiki how to

http://fedoraproject.org/wiki/PackageMaintainers/Join#Check_out_the_module

mkdir ~/fedora-scm/itools
i was trying to check out my module 
does that clear up let me know if you need further information.
Comment 4 Jesse Keating 2010-08-12 02:25:07 EDT
Looks like you didn't read the directions right.  You made a dir for the module and didn't do a clone, the instructions say to make a top dir for all the modules, then cd into that dir and do the clone.  The clone would have created the subdir for your module.

I'll trap the error anyway.
Comment 5 Jesse Keating 2010-08-12 03:23:11 EDT
I believe I have this error trapped now.
Comment 6 Fedora Update System 2010-08-12 15:53:54 EDT
python-kitchen-0.2-0.1.a2.el5,fedora-packager-0.5.1.2-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/python-kitchen-0.2-0.1.a2.el5,fedora-packager-0.5.1.2-1.el5
Comment 7 Fedora Update System 2010-08-12 15:57:27 EDT
fedora-packager-0.5.1.2-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-1.fc14
Comment 8 Fedora Update System 2010-08-12 16:01:55 EDT
fedora-packager-0.5.1.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-1.fc13
Comment 9 Fedora Update System 2010-08-12 16:07:49 EDT
fedora-packager-0.5.1.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-1.fc12
Comment 10 Fedora Update System 2010-08-13 17:06:47 EDT
fedora-packager-0.5.1.2-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-packager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-2.fc13
Comment 11 Fedora Update System 2010-08-13 18:39:26 EDT
fedora-packager-0.5.1.2-2.el5, python-kitchen-0.2-0.1.a2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-packager python-kitchen'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-kitchen-0.2-0.1.a2.el5,fedora-packager-0.5.1.2-2.el5
Comment 12 Fedora Update System 2010-08-17 01:36:21 EDT
fedora-packager-0.5.1.2-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-08-24 17:08:29 EDT
fedora-packager-0.5.1.2-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-08-24 19:04:00 EDT
fedora-packager-0.5.1.2-2.el5, python-kitchen-0.2-0.1.a2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2010-08-24 21:19:44 EDT
fedora-packager-0.5.1.2-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.