Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 622744 - /etc/rc.d/init.d/mysqld - cannot touch `/var/lock/subsys/mysqld': Permission denied
/etc/rc.d/init.d/mysqld - cannot touch `/var/lock/subsys/mysqld': Permission ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mysql (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Tom Lane
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 06:21 EDT by timlank
Modified: 2013-07-02 23:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 09:53:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description timlank 2010-08-10 06:21:08 EDT
Description of problem:
trying to start /etc/rc.d/init.d/mysqld as the mysql user results in the following error from the init script hardcoding:
touch: cannot touch `/var/lock/subsys/mysqld': Permission denied

Version-Release number of selected component (if applicable):
RHEL 5.4
mysql-server-5.0.77-4.el5_4.2.x86_64

How reproducible: every time


Steps to Reproduce:
1. login as the mysql user account
2. run /etc/rc.d/init.d/mysqld start
3.
  
Actual results: mysqld_safe and mysqld start just fine, but the lock file is not created because of permissions in of the /var/lock/subsys directory as hardcoded in the init script

Expected results:
the error would not appear

Additional info:
please have the package maintainer re-visit the explicit pathing of this lock file location in the init script
Comment 1 Tom Lane 2010-08-10 09:53:24 EDT
Not a bug --- initscripts invariably are expected to run as root.

Note You need to log in before you can comment on or make changes to this bug.