Bug 622746 - SELinux /usr/sbin/libvirtd on /proc//stat
Summary: SELinux /usr/sbin/libvirtd on /proc//stat
Status: CLOSED DUPLICATE of bug 622739
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-mls (Show other bugs)
(Show other bugs)
Version: 12
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-10 10:26 UTC by Romain Ferrari
Modified: 2010-08-10 12:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 12:28:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Romain Ferrari 2010-08-10 10:26:58 UTC
Contexte source               system_u:system_r:virtd_t:s0-s15:c0.c1023
Contexte cible                system_u:system_r:svirt_t:s0:c174,c525
Objets du contexte            /proc/<pid>/stat [ file ]
source                        libvirtd
Chemin de la source           /usr/sbin/libvirtd
Port                          <Inconnu>
Hôte                         host01
Paquetages RPM source         libvirt-0.8.2-1.fc12
Paquetages RPM cible          
Politique RPM                 selinux-policy-3.6.32-118.fc12
Selinux activé               True
Type de politique             mls
Mode strict                   Permissive
Nom du plugin                 catchall
Nom de l'hôte                host01
Plateforme                    Linux host01 2.6.32.16-150.fc12.x86_64 #1 SMP Sat
                              Jul 24 05:19:12 UTC 2010 x86_64 x86_64
Compteur d'alertes            1
Première alerte              Tue Aug 10 12:24:30 2010
Dernière alerte              Tue Aug 10 12:24:30 2010
ID local                      6496840d-db49-402c-a606-67df7cd3a02c
Numéros des lignes           

Messages d'audit bruts        

node=host01 type=AVC msg=audit(1281435870.37:37764): avc:  denied  { getattr } for  pid=1984 comm="libvirtd" path="/proc/2414/stat" dev=proc ino=20128 scontext=system_u:system_r:virtd_t:s0-s15:c0.c1023 tcontext=system_u:system_r:svirt_t:s0:c174,c525 tclass=file

node=host01 type=SYSCALL msg=audit(1281435870.37:37764): arch=c000003e syscall=5 success=yes exit=128 a0=12 a1=7f8f26bfb400 a2=7f8f26bfb400 a3=0 items=0 ppid=1 pid=1984 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="libvirtd" exe="/usr/sbin/libvirtd" subj=system_u:system_r:virtd_t:s0-s15:c0.c1023 key=(null)

Comment 1 Daniel Walsh 2010-08-10 12:28:27 UTC
Any chance you can update to F13 and do your testing there?

*** This bug has been marked as a duplicate of bug 622739 ***

Comment 2 Romain Ferrari 2010-08-10 12:32:39 UTC
I'll do that


Note You need to log in before you can comment on or make changes to this bug.