Bug 62280 - Broken rpm -27
Summary: Broken rpm -27
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: glibc   
(Show other bugs)
Version: skipjack-beta1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-29 02:29 UTC by Volkov Oleg
Modified: 2016-11-24 15:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-29 02:29:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Volkov Oleg 2002-03-29 02:29:16 UTC
glibc-2.2.5-27 is definitely broken.

Starting with problems described at:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=61868

I discovered that size of whole glibc is about 1,3M (peoples from embede world would happy!)
But a long time ago glibc size iz more than 6M. This point on compilation error
when the named rpm was created.

# ll /lib/i686/libc.so.6
lrwxrwxrwx    1 root     root           13 Mar 24 17:33 /lib/i686/libc.so.6 ->
libc-2.2.5.so
# ll /lib/i686/libc-2.2.5.so
-rwxr-xr-x    1 root     root      1400136 Mar 14 22:34 /lib/i686/libc-2.2.5.so

A long time ago libc has more than 5M. This size is very strange.
# rpm -qf /lib/i686/libc-2.2.5.so
glibc-2.2.5-27
#  rpm -V glibc
.......T c /etc/rpc

Comment 1 Jakub Jelinek 2002-03-29 09:38:26 UTC
Um, why do you think it is broken just because it decreased its size?
Previously, glibc included full debug information but 99.9% of users really
don't need it actually (especially when they don't have glibc sources installed).
So, the unstripped libraries were moved to glibc-debug and glibc-debug-static
packages and libraries in glibc package were stripped (strip -g to keep
symbol/string tables).


Note You need to log in before you can comment on or make changes to this bug.