Bug 622835 - add fix for containerless unicode float decoding
add fix for containerless unicode float decoding
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-simplejson (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 10:20 EDT by Felix Schwarz
Modified: 2016-09-19 22:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-simplejson-2.0.9-2.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-30 13:54:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Schwarz 2010-08-10 10:20:52 EDT
In EPEL, simplejson.loads(u'-2.75') will raise an exception because of http://code.google.com/p/simplejson/issues/detail?id=43 . I'd like to request inclusion of the fix into python-simplejson for EPEL as this is a simple bug fix. The bug itself is easy to hit in 'normal' use cases.

upstream fixed this in 2.1 but that release is not officially supported on Python 2.4. Also 2.1 is in some respect incompatible to 2.0.9 so we should not update python-simplejson in general but just pull in selected fixes.
Comment 1 Toshio Kuratomi 2010-08-10 12:06:51 EDT
Looks good.  Just a question of whether that's the complete fix or not.  The commit mentioned in the bug seems to only affect the .c file used for speedup, not the .py file (which I suppose wouldn't affect us since we'll always build the speedup in Fedora packages) and the unittests don't seem to be updated to test the given error condition.
Comment 2 Felix Schwarz 2010-08-10 12:18:00 EDT
yes, the pure-python version is not affected by the bug (something that confused me thoroughly until I found out - as they seemingly similar machines showed different behavior). 

I'll try to update the package (assuming that I can beat git hard enough to get it working ;-).
Comment 3 Fedora Update System 2010-08-13 07:57:38 EDT
python-simplejson-2.0.9-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/python-simplejson-2.0.9-2.el5
Comment 4 Fedora Update System 2010-08-13 18:37:36 EDT
python-simplejson-2.0.9-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-simplejson'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-simplejson-2.0.9-2.el5
Comment 5 Fedora Update System 2010-08-30 13:54:42 EDT
python-simplejson-2.0.9-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.