Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 622838 - cannot move one panel from one monitor to the other
cannot move one panel from one monitor to the other
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-panel (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 10:26 EDT by John Brier
Modified: 2013-08-14 19:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-30 13:15:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gconftool-2-R-apps-panel.txt (15.68 KB, text/plain)
2010-08-10 15:41 EDT, John Brier
no flags Details
gconftool-2-R-apps-panel.txt (15.68 KB, text/plain)
2010-08-10 15:43 EDT, John Brier
no flags Details

  None (edit)
Description John Brier 2010-08-10 10:26:22 EDT
Description of problem:

After enabling my second monitor using the nouveau driver I cannot move both of the panels to my prefferred primary display. I did move the main panel with "applications, places, system" but I cannot move the one that has the desktop switcher from the right to the left.

Additionally if I right click on the main panel and click new panel it will show up on the right monitor and I cannot move that panel either. I am holding "Alt" and clicking on a vacant space on the panel to try and move it.


Version-Release number of selected component (if applicable):


gnome-panel-libs-2.30.2-3.el6.x86_64
gnome-panel-2.30.2-3.el6.x86_64


How reproducible:
one other person was able to reproduce on #rhel6-beta


Steps to Reproduce:
1. enabled second monitor if not already enabled
2. hold alt and click on vacant space on "bottom edged" panel
3. try to move it from the monitor/desktop space it is on to the opposite.
  
Actual results:
it won't move


Expected results:
it will move to any monitor/desktop

Additional info:
Comment 2 RHEL Product and Program Management 2010-08-10 10:58:36 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Ray Strode [halfline] 2010-08-10 12:12:58 EDT
Seems to work here.

Does it work with a freshly created "test" user?

Can you attach the output of gconftool-2 -R /apps/panel and gconftool-2 /desktop/gnome/lockdown

?
Comment 4 John Brier 2010-08-10 15:41:39 EDT
Created attachment 437980 [details]
gconftool-2-R-apps-panel.txt
Comment 5 John Brier 2010-08-10 15:43:39 EDT
Created attachment 437981 [details]
gconftool-2-R-apps-panel.txt
Comment 6 John Brier 2010-08-10 15:45:45 EDT
I created a test user 'panel' and logged in. I noticed my right monitor was set as the primary so I sent to System > Preferences > Display and moved the green monitor from the right to the left. 

Then I was able to ALT + click and move *both* panels with no problem. I guess my other user is messed up. 

Now in my main user account when I ALT + click I do not get the "hand" that I get with the test user. What could cause this?

I attached the output you wanted from the broken user "jbrier" I did add the -R option to the last command because without it it didn't produce any output.
Comment 8 RHEL Product and Program Management 2010-11-30 13:15:07 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.