Bug 62284 - rpmbuild segfaults when processing files
Summary: rpmbuild segfaults when processing files
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-29 03:11 UTC by Ryan Finnie
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-20 18:18:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gzipped Tarball of SRPM, gdb backtrace, strace, and script (1.18 MB, application/octet-stream)
2002-03-29 03:13 UTC, Ryan Finnie
no flags Details

Description Ryan Finnie 2002-03-29 03:11:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
I haven't been able to isolate the exact circumstance threshold for the error,
but I will attach an SRPM that can reproduce it.  The tarball inside the SRPM is
a binary tree of /usr/local/apache for Apache 1.3.24.  Also attached are a
script output, an strace, and a gdb backtrace.  From the looks of the backtrace,
it has something to do with the nobody:nobody "proxy" directory:

Processing files: reproduce-20020328-1
(no debugging symbols found)...(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
strcmp (p1=0x0, p2=0x8077f98 "nobody") at ../sysdeps/generic/strcmp.c:38
38
../sysdeps/generic/strcmp.c: No such file or directory.
	in ../sysdeps/generic/strcmp.c

though something else contributes to the segfault, because if I remove
everything except the "proxy" directory, it works fine.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. rpm -ivh reproduce-20020328-1.src.rpm
2. rpm -ba reproduce.spec


Actual Results:  Last few lines:

apache/include/os.h
apache/include/os-inline.c
apache/logs/
apache/proxy/
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.53088
+ umask 022
+ cd /usr/src/redhat/BUILD
+ /usr/lib/rpm/brp-compress
+ /usr/lib/rpm/brp-strip
+ /usr/lib/rpm/brp-strip-comment-note
Processing files: reproduce-20020328-1
Segmentation fault



Expected Results:  No segfault, build the RPM package.

Additional info:

Comment 1 Ryan Finnie 2002-03-29 03:13:57 UTC
Created attachment 51284 [details]
Gzipped Tarball of SRPM, gdb backtrace, strace, and script

Comment 2 Jeff Johnson 2002-03-30 16:37:41 UTC
Have you tried with rpm-4.0.4?

Comment 3 Need Real Name 2002-06-20 18:18:54 UTC
IRK, forgot about this ticket.  Yeah, upgrading helped; I thought that machine 
had the latest version.


Note You need to log in before you can comment on or make changes to this bug.