Bug 62286 - SHIFT+INS Does not paste correctly
SHIFT+INS Does not paste correctly
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-28 23:30 EST by Red Hat Bugzilla
Modified: 2008-03-13 15:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-01 02:33:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2002-03-28 23:30:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
If you were to highlight some text someplace, let's say mozilla, and go paste it
into a konsole (kde) using SHIFT+INS, it does not paste the correct information.
 This was the behaviour in redhat 7.2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Highlight text
2. Hit SHIFT+INS
3. Notice that what was pasted is not the text you highlighted


Additional info:
Comment 1 Red Hat Bugzilla 2002-03-29 06:09:31 EST
I'm not sure where this fits in most appropriately as a bug report, either
mozilla, kde, qt, or something else, but cut and paste in this context
has nothing to do with XFree86, this is a higher level abstraction.

Reassigning to KDE component
Comment 2 Red Hat Bugzilla 2002-04-01 02:33:14 EST
This is similar (though opposite) to a problem I reported in the Roswell beta as
Bug 51716 having to do with the differences between KDE, Mozilla and Gnome in
how it treats the clipboard and select.  You can read about the clipboard
problems of KDE 2.2.2 interoperability at this URL:
http://www.freedesktop.org/standards/clipboards.txt

In short, the old behavior in QT2 would always copy into CLIPBOARD and PRIMARY
on select, while Gnome and Mozilla would only copy into PRIMARY.  This behavior
was very annoying to many people because it lacks consistency between
applications and made for an annoying time when you want to delete a block of
text and paste in its place (wasn't possible).

In QT3 the behavior was changed to act like Gnome and Mozilla where select will
only copy into PRIMARY, and not CLIPBOARD.  This behaves in a consistent way
across all applications, and it will not continue to be a nasty surprise for
Windows and Mac users (one of the reasons the German government mentioned when
they turned down KDE for government desktop use).

This change in behavior wont effect Unix users that like "SELECT and
middle-click" for all of their copying and pasting needs.  It will work in your
case, or alternatively you can select "Copy" after you select in Mozilla then
Shift-Ins will work in Konsole.

I'm guessing you don't like this change in behavior.  I had nothing to do with
the change, but I have to strongly agree with their reasons mentioned in that
URL above and I am very happy that it now behaves in a way that Windows and Mac
users expect.

If this is a satisfactory explanation, I would suggest this bug be closed as
NOTABUG.
Comment 3 Red Hat Bugzilla 2002-04-01 15:08:00 EST
Sounds sensible to me.
Comment 4 Red Hat Bugzilla 2002-04-01 15:14:39 EST
I don't understand exactly why SHIFT+INS can't have the same action as the
middle mouse button.  I guess, what is the proper way to copy and paste?  For
example,
I copy some text by highlighting it (in any application), what is the proper way
to paste it?  CTL+V does not work in Konsole, but does in mozilla.  Middle mouse
button works everywhere I have tested.  I am guessing that some of this is on a
per application basis.  

If I am just a misguided fool, let me know, but perhaps even a way to map the
keystroke SHIFT+INS to the 'correct' (in my eyes) action would be cool too.

Thank you!  I can learn a new method but what is the preferred, most used, best
method of copying and pasting in all applications?
Comment 5 Red Hat Bugzilla 2002-04-01 15:25:23 EST
> I don't understand exactly why SHIFT+INS can't have 
> the same action as the middle mouse button. 

Middle mouse click did this in Unix a LONG time go.  We don't want to take away 
this old select and paste behavior from the old Unix users who expect this to 
work.

Fortunately, this is almost entirely independent of the Copy/Cut/Paste behavior 
that Windows and Mac users have come to expect.  KDE3, Gnome, and Mozilla now 
treat these two methods as seperate entities, hopefully keeping both camps 
happy.

About the question of what is the "right way".  There is no right way.  I use 
both methods depending on the situation.  If you don't like either way, change 
it yourself.  It is Open Source.  You have choice.
Comment 6 Red Hat Bugzilla 2002-04-01 15:28:14 EST
One more thing.

There is one notable exception to the select/middle click.  Wine currently 
doesn't support that.

Note You need to log in before you can comment on or make changes to this bug.