This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 622876 - designer-qt4: editing main window menu does not work (no drag&drop, no hierarchical entries)
designer-qt4: editing main window menu does not work (no drag&drop, no hierar...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 12:06 EDT by Torsten Rohlfing
Modified: 2010-08-13 11:08 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 10:58:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 247664 None None None Never

  None (edit)
Description Torsten Rohlfing 2010-08-10 12:06:56 EDT
Description of problem:

Qt Designer should allow the creation of hierarchical main menus, and menu entries should be arrangeable using drag&drop. Both are broken in Fedora.

Version-Release number of selected component (if applicable):

I am running F13 with current Qt packages (qt-4.6.3-8.fc13) and KDE (kdelibs-4.4.5-1.fc13). Tried this on three different systems, two i686 and one x86_64. Also tested using KDE and LXDE as window managers, and tested current Qt beta (4.7.0-Beta2) built from source. All broken.

How reproducible:

Steps to Reproduce:
1. start "designer-qt", select "Main Window", click "Create"
2. double click "Type Here" field in menu bar, type "A", enter
3. double click "Type Here" field in open "A" menu, type "B", enter
4. click on "page-plus" icon on the right side of "B" submenu - nothing happens
5. double click on "Type Here" field in menu bar, type "C", enter
6. try to move "C" menu by dragging it - nothing gets dragged
  
Actual results:

In Step 4., nothing happens
In Step 6., nothing happens

Expected results:

In Step 4., a sub-menu should appear
In Step 6., the "C" menu should be draggable around the menu bar

Additional info:

I built the same Qt beta version (4.7.0-Beta2) on OpenSolaris, where everything worked as expected.

I previously filed this bug with the Qt bug tracker (http://bugreports.qt.nokia.com/browse/QTBUG-12589) but no one there was able to reproduce the problem - presumably they aren't using Fedora, so maybe this is related to a Fedora-specific combination of libraries?
Comment 1 Torsten Rohlfing 2010-08-13 10:58:26 EDT
The Qt guys have now been able to reproduce this - apparently it's a problem with KDE's Oxygen style. The upstream bug report for this is 

https://bugs.kde.org/show_bug.cgi?id=247664

Since it's not a Fedora-specific problem, I'll close this.
Comment 2 Rex Dieter 2010-08-13 11:08:34 EDT
Thanks, will track it there.

Note You need to log in before you can comment on or make changes to this bug.