Bug 622894 - [abrt] crash in compiz-0.8.6-1.fc13: radeon_bo_get_tiling: Process /usr/bin/compiz was killed by signal 11 (SIGSEGV)
[abrt] crash in compiz-0.8.6-1.fc13: radeon_bo_get_tiling: Process /usr/bin/c...
Status: CLOSED DUPLICATE of bug 568593
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
abrt_hash:89d1c33fd3939ed3e10ba9c5e2d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 13:39 EDT by Eric Herget
Modified: 2010-08-21 03:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-21 03:46:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (33.45 KB, text/plain)
2010-08-10 13:39 EDT, Eric Herget
no flags Details

  None (edit)
Description Eric Herget 2010-08-10 13:39:14 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: compiz --ignore-desktop-hints glib gconf gnomecompat
component: compiz
crash_function: radeon_bo_get_tiling
executable: /usr/bin/compiz
global_uuid: 89d1c33fd3939ed3e10ba9c5e2d937b8efdaebb0
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: compiz-0.8.6-1.fc13
rating: 4
reason: Process /usr/bin/compiz was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
This same issue happens on two different machines.  Both run Fedora 13 with latest updates (has been happening for a while - 2-4 months).

The machine against which this bug got created using ABRT has integrated ATI Radeon HD 4250 GPU on ASUS M4A88TD-M motherboard with AMD PhenomII X4 945 Quad-Core Processor.  lspci shows the graphics card/controller as "01:05.0 VGA compatible controller: ATI Technologies Inc Device 9715".  Loaded graphics module is "radeon", which, I believe, comes from the package xorg-x11-drv-ati-6.13.0-1.fc13.x86_64.

The other machine, where this issue shows up more frequently is a Dell Precision T5500 workstation with ATI FireMV 2260 graphics card.  lspci shows this graphics adapter as "03:00.0 VGA compatible controller: ATI Technologies Inc RV620 [FirePro 2260]".  Graphics mod is "radeon" from the identical xort-x11-drv-ati package (also 64 bit).

When the problem occurs, all window borders disappear including the minimize, maximize, close buttons and the resize widgets.  After the problem occurs, opening a new window by starting a new application from the "Applications" menu in the desktop menu bar causes the desktop menu bar (at the top of my screen) to change to the menu bar for the just-started application - I'll get "File", "Edit", "View", "Terminal" and "Help" menu items if I start a terminal.

I can "get out" of the problem by opening "System"->"Preferences"->"Desktop Effects" and change it back to "Standard".  This causes the desktop to redraw all the windows and they now have their borders and widgets back.  Then I can re-open "Desktop Effects" preferences and set it back to "Compiz".

How to reproduce
-----
1. Have desktop effects enabled
2. Seems to happen most often when I have Eclipse running (using Sun's Java 1.6.0_20)
3. Usually happens when I try to resize a window/popup
Comment 1 Eric Herget 2010-08-10 13:39:17 EDT
Created attachment 437955 [details]
File: backtrace
Comment 2 Adel Gadllah 2010-08-21 03:46:51 EDT

*** This bug has been marked as a duplicate of bug 568593 ***

Note You need to log in before you can comment on or make changes to this bug.