Bug 622898 - Improper restoration of window when button clicked in lxde task bar
Improper restoration of window when button clicked in lxde task bar
Status: CLOSED DUPLICATE of bug 629105
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 14:04 EDT by Steven Usdansky
Modified: 2010-09-07 02:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-07 02:25:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen image (should be showing firefix window in the middle area) (302.58 KB, image/jpeg)
2010-08-10 14:04 EDT, Steven Usdansky
no flags Details

  None (edit)
Description Steven Usdansky 2010-08-10 14:04:07 EDT
Created attachment 437959 [details]
screen image (should be showing firefix window in the middle area)

Description of problem:
Window does not always properly restore when clicking on button in lxde taskbar. Sometimes one sees a repeated section of the background where the restored window should be, sometimes nothing. Appears to happen irrespective of application being minimized (have encountered this with geany, lxterminal, firefox)

Version-Release number of selected component (if applicable):
F14 branched (64-bit) LXDE spin from 8-Aug nightly compose updated 10-Aug

How reproducible:
irregular, but once it happens, fairly frequently


Steps to Reproduce:
1. Open firefox (or lxterminal or geany)
2. minimize to task bar
3. click on appropriate taskbar button to restore
  
Actual results:
Repeated background segments in place of restored window


Expected results:
Restored window of minimized app

Additional info:
Have not seen problem with 32-bit install; I believe all components are and configs identical (except for 64-bit vs. 32-bit). 

~$ rpm -qa | grep ^lx
lxappearance-0.4.0-2.fc14.x86_64
lxrandr-0.1.1-3.fc13.x86_64
lxterminal-0.1.8-1.fc14.x86_64
lxmenu-data-0.1.1-3.fc13.noarch
lxsession-edit-0.1.1-4.fc13.x86_64
lx-20030328-5.fc12.x86_64
lxpolkit-0.1.0-0.1.20100402git5087383.fc14.x86_64
lxde-common-0.5.4-2.fc14.noarch
lxlauncher-0.2.1-7.fc14.x86_64
lxtask-0.1.3-1.fc14.x86_64
lxpanel-0.5.6-1.fc14.x86_64
lxsession-0.4.4-1.fc14.x86_64
lxdm-0.2.0-4.fc14.x86_64
lxinput-0.1.1-4.fc14.x86_64
lxshortcut-0.1.1-3.fc13.x86_64

Other possiblly relevant packages:
openbox-3.4.11.2-2.fc14.x86_64
obconf-2.0.3-4.fc12.x86_64
xorg-x11-drv-nouveau-0.0.16-9.20100615gitdb98ad2.fc14.x86_64
mesa-dri-drivers-experimental-7.9-0.6.fc14.x86_64
Comment 1 Miroslav Lichvar 2010-08-11 05:36:26 EDT
This could be a driver problem.
Comment 2 Steven Usdansky 2010-08-11 08:23:49 EDT
Forgot to mention that xcompmgr (xcompmgr-1.1.5-1.fc13.x86_64) was running when the error occurred. Just tried creating a new user to see if I could recreate the problem, but did not create ~/.config/autostart so xcompmgr wasn't started by default (xcompmgr is started by default for my normal user). New user did not experience the problem until I ran xcompmgr; then the next attempt to restore a window from the task bar gave the problem.
Comment 3 Steven Usdansky 2010-08-12 08:26:02 EDT
I have not been able to reproduce the problem in my 32-bit install - even tried killing and restarting xcompmgr, to no avail.
Comment 4 Steven Usdansky 2010-08-13 10:25:25 EDT
Jusyt tried LXDE spin x86_64 alpha RC4. Same problem, but this time, I had a terminal open and got repeating errors whenever I clicked on the LXTerminal button onthe task bar. FWIW, the block below was from a single click.

error 8: BadMatch (invalid parameter attributes) request 148 minor 4 serial 176344
error 159: BadPicture request 148 minor 7 serial 176551
error 8: BadMatch (invalid parameter attributes) request 148 minor 4 serial 176580
error 159: BadPicture request 148 minor 7 serial 176695
error 8: BadMatch (invalid parameter attributes) request 148 minor 4 serial 176721
error 159: BadPicture request 148 minor 7 serial 177247
error 8: BadMatch (invalid parameter attributes) request 148 minor 4 serial 177271
error 159: BadPicture request 148 minor 7 serial 177623
error 8: BadMatch (invalid parameter attributes) request 148 minor 4 serial 177647
error 159: BadPicture request 148 minor 7 serial 178319
error 8: BadMatch (invalid parameter attributes) request 148 minor 4 serial 178345
error 159: BadPicture request 148 minor 7 serial 178733
error 8: BadMatch (invalid parameter attributes) request 148 minor 4 serial 178757
error 159: BadPicture request 148 minor 7 serial 179838
error 8: BadMatch (invalid parameter attributes) request 148 minor 4 serial 179864
error 159: BadPicture request 148 minor 7 serial 180574
error 8: BadMatch (invalid parameter attributes) request 148 minor 4 serial 180598
error 159: BadPicture request 148 minor 7 serial 181587
error 8: BadMatch (invalid parameter attributes) request 148 minor 4 serial 181613
Comment 5 Ben Skeggs 2010-09-07 02:25:31 EDT

*** This bug has been marked as a duplicate of bug 629105 ***

Note You need to log in before you can comment on or make changes to this bug.