Bug 62293 - Device couldn't be opened for scanning
Device couldn't be opened for scanning
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: sane-backends (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-29 04:00 EST by Joachim Kunze
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-18 15:01:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Kunze 2002-03-29 04:00:46 EST
Description of Problem:
scanner was found by the scsi driver
sane-find-scanner finds also the scanner
neither xscanimage nor xsane can open the device to scan

in the previous version of skipjack scanning worked pretty well

Version-Release number of selected component (if applicable):
sane-backends-1.0.7-6
Comment 1 Bill Nottingham 2002-04-01 15:03:58 EST
Previous versions? Do you mean in 7.2, or just before applying skipjack updates?
Comment 2 Joachim Kunze 2002-04-04 12:15:22 EST
It worked pretty well until 7.2 and with the 2.4.9-versions of Skipjack. From
the 2.4.18-based versions on scanning don't work.
Unfortunately with the change to the 2.4.18 kernels also the sane-versions
changed, but with a try with 2.4.9-31 I had the same problem :-(
Comment 3 Tim Waugh 2002-04-05 09:22:47 EST
2.4.9-version of skipjack??

Please confirm the versions of both the kernel and sane-backends when it last
worked.  Also, are you trying this as root or as a non-root user?

What model of scanner is this?  Do you have a symlink /dev/scanner? (If not
you'll need to make one.)
Comment 4 Joachim Kunze 2002-04-06 10:00:30 EST
Sorry I was not precise enough - I meant the 2.4.9-x kernel-based Skipjack versions.

The symlink to the right device exists

Last time it worked with the following versions:
kernel: 2.4.9-31
sane-backends: 1.0.7-4 or previous (here I'm not sure)

The scanner is a Mustek 12000SP (SCSI) and it worked from 7.0-7.2 without any
problems
The SCSI-controller is an Adaptec 2940 UW.

It neither works as root nor as a user.
Comment 5 Tim Waugh 2002-04-08 06:58:25 EDT
Can you try backing off to a kernel/sane-backends combination that you can test
works, so that we can find out if it's a kernel problem or a SANE one?

Thanks. (You can use the --oldpackage rpm flag to 'upgrade' to older versions.)
Comment 6 Joachim Kunze 2002-04-13 04:11:18 EDT
I've tested a lot the last week wtiht the following results:
- when I use the sane-backends-1.0.5-4 or sane-backends-1.0.5-4.1 it works
pretty well with all kernel versions from 2.4.9-31 till 2.4.18-0.21
- when I switch to a version of sane >= 1.0.7-4, xsane can't detect the device
Hope that helps.
Unfortunately I'm on holiday from tomorrow on.
Comment 7 Tim Waugh 2002-05-02 09:38:08 EDT
Please show me the output of 'cat /proc/scsi/scsi'.
Comment 8 Joachim Kunze 2002-05-02 15:07:35 EDT
Et voil`
-------------------------------------------------------------------------
Attached devices: 
Host: scsi0 Channel: 00 Id: 05 Lun: 00
  Vendor: SCANNER  Model:                  Rev: 2.02
  Type:   Scanner                          ANSI SCSI revision: 01 CCS
Host: scsi0 Channel: 00 Id: 06 Lun: 00
  Vendor: ARCHIVE  Model: Python 04106-XXX Rev: 727A
  Type:   Sequential-Access                ANSI SCSI revision: 02
Comment 9 Tim Waugh 2002-06-13 06:53:13 EDT
I'm pretty sure that this is fixed in 1.0.8. 
 
You might be able to work around it by changing 'scsi SCANNER' in 
/etc/sane.d/mustek.conf to 'scsi * * Scanner'.
Comment 10 Joachim Kunze 2002-06-15 16:52:20 EDT
Sorry - I tried the recommended changements in /etc/sane.d/mustek.conf, but the
scanner is still not recognized by xsane.
On another machine with a completely different configuration (only the Adaptec
2940 UW is the same type) I received the same result wit a microtek scanner.
Using the old 7.2 packages resolved the problem.
Comment 11 Tim Waugh 2002-06-17 08:48:52 EDT
Are you able to try rebuilding 1.0.8 from source?  There is a .src.rpm in 
rawhide (ftp.redhat.com/pub/redhat/linux/rawhide/).. 
Comment 12 Joachim Kunze 2002-06-18 15:01:34 EDT
Hi Tim,

no problem - already compiled, installed and it works on both machines pretty
fine now. Thank you very much - can we in Germany expect a german version soon?
What about ocr support?

Regards,

Joachim

Note You need to log in before you can comment on or make changes to this bug.