Bug 622944 - imports from same user with new data will not import
Summary: imports from same user with new data will not import
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin   
(Show other bugs)
Version: 0.5
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Bryan Kearney
QA Contact: wes hayutin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-10 20:49 UTC by wes hayutin
Modified: 2015-05-14 15:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 13:03:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
catalina.out (101.30 KB, text/plain)
2010-08-10 20:51 UTC, wes hayutin
no flags Details

Description wes hayutin 2010-08-10 20:49:37 UTC
Description of problem:

recreate:
1. register to candlepin, subsribe to pools
2. export the data, save to export1
3. subscribe to some more pools 
4. export the data save to export2

5. import export1
6. import export2 -FAIL


Starting tomcat6:                                          [  OK  ]
Initializing Candlepin...
Initialized!
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

Please point IMPORTDIR to the location of the product data 

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
[root@localhost proxy]# curl -u admin:admin -k -F export=@/tmp/export810-1.zip https://localhost:8443/candlepin/owners/1/import

[root@localhost proxy]# curl -u admin:admin -k -F export=@/tmp/export810-2.zip https://localhost:8443/candlepin/owners/1/import
<?xml version="1.0" encoding="UTF-8" standalone="yes"?><exceptionMessage><displayMessage>Runtime Error org.hibernate.PropertyValueException: not-null property references a null or transient value: org.fedoraproject.candlepin.model.ProductAttribute.product at org.hibernate.engine.Nullability.checkNullability:95</displayMessage></exceptionMessage>[root@localhost proxy]#

Comment 1 wes hayutin 2010-08-10 20:51:35 UTC
Created attachment 437999 [details]
catalina.out

Comment 2 Ajay Kumar Nadathur Sreenivasan 2010-11-09 16:26:47 UTC
Hi,
I am not able to reproduce the above scenario. After eye balling the source code, I believe that the source has changed and probably the above problem has been fixed.

Comment 4 spandey 2011-08-26 07:43:15 UTC
subscription-manager subscribe --pool ff8080813204d173013204d2a61a0707
subscription-manager subscribe --pool ff8080813204d173013204d2a16a0625
curl -k -u admin:admin https://10.65.193.123:8443/candlepin/consumers/2b95f15c-926f-43fe-a59f-eee0f7704c4e/export >> export1.zip

[root@dhcp201-207 ~]# subscription-manager subscribe --pool ff8080813204d173013204d29f4a05a7
Successfully subscribed the system to Pool ff8080813204d173013204d29f4a05a7
[root@dhcp201-207 ~]# subscription-manager subscribe --pool ff8080813204d173013204d29f4a05a7
Successfully subscribed the system to Pool ff8080813204d173013204d29f4a05a7
[root@dhcp201-207 ~]# curl -k -u admin:admin https://10.65.193.123:8443/candlepin/consumers/2b95f15c-926f-43fe-a59f-eee0f7704c4e/export >> export2.zip
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 46498  100 46498    0     0  10490      0  0:00:04  0:00:04 --:--:-- 17480


[root@dhcp201-207 ~]# subscription-manager list --avail >> list1
[root@dhcp201-207 ~]# curl -u admin:admin -k -F export=@export1.zip https://10.65.193.169:8443/candlepin/owners/admin/imports
[root@dhcp201-207 ~]# subscription-manager list --avail >> list2
[root@dhcp201-207 ~]# curl -u admin:admin -k -F export=@export2.zip https://10.65.193.169:8443/candlepin/owners/admin/imports
[root@dhcp201-207 ~]# subscription-manager list --avail >> list3


sucessfully imported working fine 

Moving defect status from on_qa to verified

Comment 5 Bryan Kearney 2012-07-17 13:03:38 UTC
Marking all community bugs modified or beyong as closed.


Note You need to log in before you can comment on or make changes to this bug.