Bug 62295 - (Mobile Athlon) reboot hang, IDE led stuck
(Mobile Athlon) reboot hang, IDE led stuck
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-29 05:07 EST by Warren Togami
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 13:41:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"dmesg" output (8.23 KB, text/plain)
2002-03-29 05:25 EST, Warren Togami
no flags Details
"lspci -v" output (4.44 KB, text/plain)
2002-03-29 05:25 EST, Warren Togami
no flags Details
dmidecode output (suggested by Mandrake kernel developer) (6.15 KB, text/plain)
2002-03-29 05:26 EST, Warren Togami
no flags Details

  None (edit)
Description Warren Togami 2002-03-29 05:07:18 EST
From Bugzilla Helper:    
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0; Linux)    
    
Description of problem:    
Rebooting Skipjack causes the Sony Vaio PCG-FXA36 laptop to be stuck at the    
BIOS screen with the IDE led stuck on.  It sometimes shows a keyboard stuck    
error, but most of the time shows a graphical Sony logo that completely blocks    
obscures the BIOS text info.    
    
Testing:    
kernel-2.4.7-10.*.rpm FAILS to boot with kernel oopses.    
kernel-2.4.9-31.athlon.rpm HANGS on reboot    
kernel-2.4.18-0.[4-12].athlon.rpm HANGS on reboot    
kernel-2.4.9-31.i686.rpm SUCCESS in reboot    
kernel-2.4.18-0.[4-12].i686.rpm SUCCESS in reboot    
    
It seems that Red Hat i686 kernel packages do not exhibit this problem, while    
athlon kernel packages do.  It may be notable to mention that both i586 and    
athlon arch packages of Mandrake 8.2 do not reboot properly, so they may be    
compiling in different options that trigger this.    
    
Version-Release number of selected component (if applicable):    
skipjack-beta1    
    
How reproducible:    
Always    
    
Additional info:   
1. Mandrake 8.2 on this machine has the same problem.    
2. MandrakeForum has some reports of non-laptop Athlon machines exhibiting    
this behavior.   
3. eric@interplas.com owns the same model Sony FXA-36 laptop and has reported    
the same problem to the Skipjack mailing list.  (All current FXA series 
laptops have the same motherboard chipset, but different processors.)
Comment 1 Warren Togami 2002-03-29 05:20:41 EST
I forgot to mention that "noathlon" kernel option did not change test results 
of the failed kernels above.
Comment 2 Warren Togami 2002-03-29 05:25:14 EST
Created attachment 51324 [details]
"dmesg" output
Comment 3 Warren Togami 2002-03-29 05:25:51 EST
Created attachment 51325 [details]
"lspci -v" output
Comment 4 Warren Togami 2002-03-29 05:26:51 EST
Created attachment 51326 [details]
dmidecode output (suggested by Mandrake kernel developer)
Comment 5 Warren Togami 2002-04-01 01:47:07 EST
This problem did not exist in earlier athlon arch kernels.  Would it be possible
for me to have access to older athlon Rawhide kernel builds in order to do
testing to find when this bug was introduced?
Comment 6 Warren Togami 2002-04-21 00:58:35 EDT
This page http://www.myplc.com/sony/vaio_unix_guide.htm thinks that this is a 
hard drive controller issue.  One guy recompiled the Rawhide kernel with 
experimental ACPI and it prevented the reboot freeze.  Installing the i686 arch 
kernel rather than athlon arch also prevents the reboot freeze.
Comment 7 Warren Togami 2002-05-09 04:01:46 EDT
Still exists in Red Hat 7.3 release.
Comment 8 James J Myers 2002-06-07 17:14:06 EDT
I have the same problem on 7.2 and 7.3
Comment 9 Warren Togami 2002-06-07 17:21:17 EDT
For now you can use the i686 kernel to avoid this reboot bug.  Alternatively you
can compile yourself an ACPI capable kernel, although you will want to use the
latest 2.4.19-pre- Alan Cox kernel to have a working ACPI implementation that
doesn't crash.
Comment 10 Arjan van de Ven 2002-06-07 17:25:01 EDT
I fail to see how ACPI could make *ANY* difference in this.
The only difference between the athlon and i686 kernel is how memcpy() is
implemented....
Comment 11 Warren Togami 2002-06-07 17:45:54 EDT
APM athlon gets stuck in reboot with IDE light stuck on.
APM i686 reboots fine.
ACPI athlon reboots fine.
ACPI i686 reboots fine.

I can't explain it.  I only know this through empirical testing.
Comment 12 Warren Togami 2002-07-04 08:55:12 EDT
Compaq Presario 700 series with Mobile Athlon or Duron processor has the same
hang in BIOS with HD light stuck on after rebooting from Red Hat athlon
optimized kernel.  rpm --force installing the i686 kernel RPM fixes this problem
on this series of laptops too.

This may be more generally a "Mobile Athlon w/ certain VIA Chipset" problem.


Comment 13 Warren Togami 2002-08-05 06:59:19 EDT
Confirmed still hangs after reboot with athlon kernel-2.4.18-7.80, but not i686
kernel-2.4.18-7.80 of Limbo2.
Comment 14 Arjan van de Ven 2002-08-05 07:04:17 EDT
Ok I think I have a handle on this, it seems you bios doesn't like the LOCAL
APIC config option, which happened to be turned on for Athlon and off for i686
Comment 15 Warren Togami 2002-08-05 08:06:11 EDT
Would a permanent solution in the kernel be possible, or we must always use a
the i686 workaround?
Comment 16 Arjan van de Ven 2002-08-05 08:16:01 EDT
I've disabled local apic for athlon kernels too in the config, that'll be in the
next build
Comment 17 Warren Togami 2002-08-12 07:25:52 EDT
kernel-2.4.18-0.75.athlon reboot SUCCESS
kernel-2.4.18-0.75.i686   reboot FAIL
kernel-2.4.18-0.75.i586 reboot SUCCESS
kernel-2.4.18-0.75.i386 reboot SUCCESS

Should close bug?
Comment 18 Warren Togami 2002-08-16 06:47:12 EDT
Anaconda using kernel-2.4.18-10.99 locks up after reboot.  Can this fix be
applied to that kernel too?
Comment 19 Jay Turner 2002-08-19 09:31:47 EDT
So, looks like we still need to do something with the boot kernel, but since we
don't run separate boot kernels (per arch) not sure what the correct fix is
here.  Reopening to get an answer.
Comment 20 Arjan van de Ven 2002-08-19 09:33:59 EDT
Unfortionatly we can't do this for the BOOT kernel since that would disable the
workaround needed for buggy 440GX chipset bioses ;(
Comment 21 Warren Togami 2002-08-23 06:42:57 EDT
Reproduced this problem on the Compaq Presario 900US.  This laptop has an ALi
chipset, unlike the Sony Vaio FXA series and Presario 700 series which both have
VIA.  This may be indicative that this is more generally a Mobile Athlon kernel
problem.

Unrelated bug:
This Presario 900 series laptop seems completely inoperative with the ALI IDE
kernel drivers, failing after over a minute of attempting to access the hard
drive or CD-ROM IDE devices.  I am testing it with various other kernels tomorrow.
Comment 22 Alan Cox 2002-08-23 06:48:08 EDT
If the ALi problem is present in the Null beta kernel please open a seperate bug
for it and stick alan@redhat.com in the cc line. 

Thanks
Comment 23 Warren Togami 2002-08-23 08:43:55 EDT
Bug 72387: (Compaq Presario 900) ALI15X3 IDE fails
Bug 72388: (Compaq Presario 900) 8139too module fails
Comment 24 Need Real Name 2002-10-27 21:36:25 EST
Hi:

I have a Sony Vaio FXA47 with Red Hat 8.0 and kernel 2.4.18-17.8.0. Guess what,
systems still hangs when rebooting, displaying the Sony logo and the LED is
stuck. IF you wait some time, the BIOS eventually tells you that there was a
keyboard error. I checked the config and it says "Local APIC support on
uniprocessors" is disabled, but the problem persists.

Any chances on seeing this issue fixed?
Thanks,

Luis Delgado (Curly Howard)
pangair@netscape.net
Comment 25 Warren Togami 2002-10-28 00:05:22 EST
pangair@netscape.net,
Are you sure that you installed the athlon arch kernel?
Comment 26 Need Real Name 2002-10-28 20:13:55 EST
How do I check that out?

Thanks.
Comment 27 Warren Togami 2002-10-30 04:43:33 EST
pangair@netscape.net,

Sorry I'm not exactly sure how to check which arch kernel is currently running.
 Arjan will know.

Oh BTW, could you please read Bug 74315.  Our laptops are virtually the same
except for the BIOS revision (which you can flash to be the same.)  Could you
please read Bug 74315 and check if you experience this problem too?

Thanks,
Warren
Comment 28 Warren Togami 2003-01-03 05:24:06 EST
Within Phoebe, still locks up in BIOS after rebooting from the BOOT kernel, but
athlon arch kernel is fine.
Comment 29 Arjan van de Ven 2003-02-05 10:21:50 EST
supposed to be fixed in recent kernels; apic is off for the BOOT kernel
Comment 30 Warren Togami 2003-02-23 05:20:58 EST
Phoebe3's installer no longer locked up after installation.  Seems fixed.

Note You need to log in before you can comment on or make changes to this bug.