Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 623017 - Trying to get network access and failing leads to error
Trying to get network access and failing leads to error
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 623151
  Show dependency treegraph
 
Reported: 2010-08-11 02:18 EDT by Sandro Mathys
Modified: 2012-05-31 02:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-14.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 623151 (view as bug list)
Environment:
Last Closed: 2012-05-31 02:53:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the traceback (168.96 KB, image/png)
2010-08-11 07:22 EDT, Radek Vykydal
no flags Details
cancel -> traceback (15.07 KB, image/png)
2010-08-11 07:45 EDT, Radek Vykydal
no flags Details
the second traceback (77.66 KB, image/png)
2010-08-11 08:48 EDT, Radek Vykydal
no flags Details

  None (edit)
Description Sandro Mathys 2010-08-11 02:18:42 EDT
Description of problem:
If in Fedora 14 Alpha RC2 x86_64 you try to activate additional repositories you're asked to setup a network connection. I tried wlan0 first and failed (probably PEBKAC), then tried eth0 and failed (probably HW issue). So I canceled setting up the network and ended with an error popup which let me exit or debug. That got me the following message:
/usr/lib64/python2.7/site-packages/pyanaconda/iw/network_gui.py(194)selectInstallNetDeviceDialog()


Version-Release number of selected component (if applicable):
- anaconda 14.15
- whatever is on the F14 Alpha RC2 DVD

How reproducible:
Not tried

Steps to Reproduce:
1. Go through the installation
2. Select the update repo
3. Try to activate wlan0 and fail (like wrong WPA2 passphrase) and cancel that
4. Try to activate eth0 and fail (like no cable or no ip from dhcp) and cancel that
5. Cancel network activation
  
Actual results:
Error popup to exit or debug

Expected results:
Updates repo deselected, being able to continue installation

Additional info:
After I chose debug and got that message in the tty, I was able to continue the installation.
Comment 1 Radek Vykydal 2010-08-11 07:22:13 EDT
Created attachment 438160 [details]
screenshot of the traceback
Comment 2 Radek Vykydal 2010-08-11 07:45:08 EDT
Created attachment 438165 [details]
cancel -> traceback

Thanks for the report.

The bug (traceback) can occurs when choosing [Cancel] in device selection dialog of stage 2 network enablement (see the screenshot).

Sending patch for review.
Comment 3 Radek Vykydal 2010-08-11 08:48:56 EDT
Created attachment 438179 [details]
the second traceback

After fixing the first traceback, second one (attached) occurs. This one is caused by the fact that we don't disable/remove temporarily added repo after failed network enablement, so next try ([Ok] in Edir Repository dialog) leads to duplicate repos error which manifests itself with the traceback instead of error message because bug #623080.

I am going to send a patch fixing also this issue in scope of this bug to anaconda-devel-list.
Comment 4 Radek Vykydal 2010-08-12 07:52:24 EDT
(In reply to comment #3)

> 
> I am going to send a patch fixing also this issue in scope of this bug to
> anaconda-devel-list.    

No, I'm going to open separate bug #623639 for the issue.
Comment 5 Radek Vykydal 2010-08-12 10:57:03 EDT
This if fixed in master in anaconda-14.15-1, after alpha release, I'll push to f14-branch.
Comment 6 Radek Vykydal 2010-08-13 02:44:10 EDT
(In reply to comment #5)
> This if fixed in master in anaconda-14.15-1

oops, anaconda-15.0-1 that will be
Comment 7 Radek Vykydal 2010-08-24 11:32:33 EDT
This should be fixed in anaconda-14.17-1 (F14 Beta).
Comment 8 Sandro Mathys 2010-10-18 16:08:43 EDT
Can't reproduce this with anaconda 14.19 (i.e. F14 Final TC1.1) anymore.

Note You need to log in before you can comment on or make changes to this bug.