This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 623034 - failed to start kickstart install when provide ks file with hd device path
failed to start kickstart install when provide ks file with hd device path
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Beta/F14BetaBlocker
  Show dependency treegraph
 
Reported: 2010-08-11 03:21 EDT by Liam Li
Modified: 2010-08-11 23:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 23:01:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Liam Li 2010-08-11 03:21:55 EDT
Description of problem:
The kickstart install failed to start when follow these steps

Version-Release number of selected component (if applicable):
anaconda14.15

How reproducible:
always

Steps to Reproduce:
1. copy a kickstart file to /dev/vda1. we can do like this:
* boot install on an installed system, this system should have a /dev/vda1
* when anaconda started, press Ctrl+Alt+F2 to tty2
* mkdir aa; mount /dev/vda1 aa
* scp remote/ks.cfg aa
2. reboot,and restart install, in grub command line, enter: ks=hd:/dev/vda1:/ks.cfg
3.
  
Actual results:
the kickstart install did not start, only anaconda was started. press Ctrl+Alt+F2 to tty2, mount /dev/vda1 /dir, cd /dir to check the ks.cfg, the file was zero, the content of file was lost.

Expected results:
the kickstart install should start
Comment 1 James Laska 2010-08-11 09:14:46 EDT
Good catch Liam!  Are you able to access the installer log files (/tmp/*log)?  If so, can you please attach them to the bug report?  Alternatively, screenshots of tty3, tty4 and tty5 might be okay in a pinch.  Thanks!

Adding to F14Beta per the following beta release criteria:

  "The installer must be able to use all kickstart delivery methods "
Comment 2 Liam Li 2010-08-11 23:01:12 EDT
This may due to a virtual machine's issue, I retested on real machine today, can not reproduce it again, I will have more tests later.SO close it as NOTABUG first. Thanks

Note You need to log in before you can comment on or make changes to this bug.