This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 623062 - [RFE] Log dependency versions too
[RFE] Log dependency versions too
Status: CLOSED DUPLICATE of bug 555205
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Target
  Show dependency treegraph
 
Reported: 2010-08-11 04:33 EDT by Nicolas Mailhot
Modified: 2015-02-01 17:52 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-27 12:54:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2010-08-11 04:33:21 EDT
Description of problem:

Abrt currently logs the version of the package that crashed. However, it does not log the versions of all the packages the crasher depended on (even though they are used via debuginfos to create backtraces, and the bug can actually be in one of the libs used).

On systems that sync with repositories whith a high churn (rawhide, pre-alpha/beta repositories/tags), or on systems that cherry-pick updates (Fedora systems manually updated from koji, RHEL systems used by conservative customers that filter heavily Red Hat-provided updates) it is far from trivial to deduce the exact dependency versions from the version of the crashing package. (Sometimes people even selectively downgrade components to help third-party software installation)

Abrt should collect this info when a crash is detected (it's just a rpm -q --whaprovides library-listed-in-backtrace) and add it to the collected info by default (not do a full sosreport).


Version-Release number of selected component (if applicable):
abrt-1.1.10-4.fc14
Comment 1 Jiri Moskovcak 2011-03-27 12:54:17 EDT

*** This bug has been marked as a duplicate of bug 555205 ***

Note You need to log in before you can comment on or make changes to this bug.