Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 623067 - Failed to install using an FTP installation resource
Failed to install using an FTP installation resource
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-11 04:58 EDT by MingtaoNiu
Modified: 2010-10-06 15:49 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-06 15:49:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pic of err when installing using an FTP installation resource (101.04 KB, image/png)
2010-08-11 21:18 EDT, MingtaoNiu
no flags Details
anaconda.log for FTP error (9.17 KB, text/plain)
2010-08-12 22:24 EDT, MingtaoNiu
no flags Details
file "syslog" for the err when installing using a FTP resource (42.97 KB, text/plain)
2010-08-15 23:22 EDT, MingtaoNiu
no flags Details

  None (edit)
Description MingtaoNiu 2010-08-11 04:58:40 EDT
Description of problem:

Failed to install using an NFS installation source

Version-Release number of selected component (if applicable):


How reproducible:
anaconda14.15
F14-alpha-rc3

Steps to Reproduce:
   1.  Boot and initiate an install using any installation source (e.g. boot.iso, CD, DVD or pxeboot)
   2. Proceed through the installer until the Software Selection step
   3. At the software selection step, click Add additional software repositories and provide the information listed. If more than one package repository is listed, you may also click Modify repository for an existing unselected entry. Enter the following information, then select OK
          * Repository type - HTTP/FTP
          * Repository URL -

            ftp://download.englab.nay.redhat.com/pub/fedora/linux/development/14/i386/os
          * Uncheck URL is a mirror list

Actual results:

Unable to read package metadata from repository

Detail info is in the attachment

Expected results:
   1.  The package metadata from additional repository is read correctly
   2. The expected packages or package groups provided by additional repository appear on the package detail screen
   3. Anaconda completes and system reboots successfully
   4. The checked packages provided by additional repository are installed in the system 

Additional info:
Succeeded to install using an NFS resource by "askthod"
Comment 1 MingtaoNiu 2010-08-11 05:31:27 EDT
Version-Release:

anaconda14.15
F14-alpha-rc3

How reproducible:
100%
Comment 2 MingtaoNiu 2010-08-11 05:42:43 EDT
:1,$/s/NFS/FTP/g

sorry for the mistakes...
Comment 3 He Rui 2010-08-11 07:57:38 EDT
Note that ftp install only failed by running this test:
https://fedoraproject.org/wiki/QA:Testcase_Additional_Ftp_Repository


Repo=ftp:// and askmethod(using ftp source) work as expected.
Comment 4 Adam Williamson 2010-08-11 12:29:03 EDT
Could it have been a transient mirror error? Did you try the test more than once? Seems like it's unlikely that the *installer* would cause a repo problem...

I see "Detail info is in the attachment", but there isn't an attachment :)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2010-08-11 15:48:01 EDT
The release criterion related to this bug is:

"The installer must be able to use at least one of the HTTP or FTP remote package source options "

We actually meant that to be about the *main installation source* - so doing an install from boot.iso using FTP or HTTP repositories, not adding FTP or HTTP repositories to a DVD install. Doing an install that way works. Also, adding an HTTP source to a DVD install works - it has a green tick from Liam in the table. So either way you can interpret the criterion, it's satisfied. Hence this bug does not block the Alpha. (Just adding this for clarification before go/no-go meeting).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 MingtaoNiu 2010-08-11 21:18:01 EDT
Created attachment 438322 [details]
pic of err when installing using an FTP installation resource

This is the pic of err when installing using an FTP installation resource
Comment 7 Jiri Skala 2010-08-12 08:01:20 EDT
Hi,
could you provide logs using Ctrl+Alt_F2 then /tmp/anaconda.log, ...

Thanks, Jiri
Comment 8 MingtaoNiu 2010-08-12 22:24:39 EDT
Created attachment 438572 [details]
anaconda.log for FTP error

anaconda.log for FTP error
Comment 9 Liam Li 2010-08-13 02:36:50 EDT
This would not happen when the repo version is the same as boot media, like all are rc4. But if boot media is rc3, but repo version is rc4, may cause this issue. But I think anaconda should read correctly, no matter what version of repo(like rc1, rc2, rc3, etc..).
Comment 10 He Rui 2010-08-13 04:21:08 EDT
Interestingly, if I add a nfs or http repo in advance at the repository selection step, then the same ftp repo can be retrieved successfully. So in my case, this issue happens when I firstly add a ftp repo.
Comment 11 Jiri Skala 2010-08-13 09:27:19 EDT
HTTP links work fine. The issue is generated using FTP links.

Unfortunately this issue has nothing to do with ftp package. Therefore I'm going to set needinfo flag and ask for some ideas from maintainers of curl/libcurl and yum.
Comment 12 Jiri Skala 2010-08-13 09:32:11 EDT
Oops, one of intended addresses was not saved by BZ.
Comment 13 Kamil Dudka 2010-08-13 09:52:16 EDT
Right, anaconda uses libcurl as the FTP client.

How can I repeat the issue with a public ftp server?
Comment 14 Kamil Dudka 2010-08-13 09:54:53 EDT
10.66.65.86 is not accessible from my network, so that I am getting the same result:

$ curl -v ftp://10.66.65.86/pub/iso/repodata/repomd.xml
* About to connect() to 10.66.65.86 port 21 (#0)
*   Trying 10.66.65.86... Connection timed out
* couldn't connect to host
* Closing connection #0
curl: (7) couldn't connect to host
Comment 15 Chris Lumens 2010-08-13 10:37:09 EDT
Please also attach /tmp/syslog to this bug report.  It looks to me like the network simply isn't active.
Comment 16 MingtaoNiu 2010-08-15 23:22:39 EDT
Created attachment 438885 [details]
file "syslog" for the err when installing using a FTP resource
Comment 17 Chris Lumens 2010-10-06 15:49:03 EDT
I am unable to reproduce this problem locally.

Note You need to log in before you can comment on or make changes to this bug.