Bug 62307 - (Japanese XIM) Mozilla needs over-the-spot by default
(Japanese XIM) Mozilla needs over-the-spot by default
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla (Show other bugs)
limbo
All Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks: 61901 67218
  Show dependency treegraph
 
Reported: 2002-03-29 09:09 EST by Warren Togami
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-23 04:40:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mozilla-xim-style.patch (Should not be patched before %patch12) (385 bytes, patch)
2002-07-23 04:34 EDT, Nakai
no flags Details | Diff

  None (edit)
Description Warren Togami 2002-03-29 09:09:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
Ever since Red Hat 7.2, Mozilla has been very problematic in behavior with
kinput2.  Inputting with kinput2 XIM would never put the kinput2 window below
the current typing location like other Japanese capable applications, and often
the kinput2 hint window would be obscured on the very bottom of the screen,
covered by the Gnome or KDE panel.  As a result, Mozilla is almost unusable in
Japanese, which is a pity because fonts are much better rendered than within
Netscape (which is often unreadably ugly or stacked on top of each other).

Here is a screenshot of kinput2 working properly in Netscape 4.7x.  Notice how
it puts the kinput2 window right under the  textbox.
http://www.mplug.org/archive/2002/kinput2_netscape_before.png
Now here is another screenshot of Netscape after inputting several Japanese
characters.  This is working properly.
http://www.mplug.org/archive/2002/kinput2_netscape_after.png

In this screenshot below you can see Mozilla not handling placement of the
kinput2 window properly.  (Look in the bottom left.)
http://www.mplug.org/archive/2002/kinput2_mozilla_before.png
This next screenshot shows why it is annoyingly impossible to use kinput2 with
Mozilla.  The kinput2 window is almost completely off the screen after you have
inputted characters.
http://www.mplug.org/archive/2002/kinput2_mozilla_after.png

Here is screenshot of kterm using kinput2 properly.
http://www.mplug.org/archive/2002/kinput2_kterm_working.png

Version-Release number of selected component (if applicable):
Skipjack beta-1 with up2date (3-27-2002)
But this is the EXACT same behavior of all versions of Mozilla with kinput2
since Red Hat 7.2.

How reproducible:
Always

Fix:
I suspect that kinput2 needs some kind of hints from the parent application
about placing the kinput2 window, and Mozilla is currently not doing that.  I
could be completely wrong though...
Comment 1 Warren Togami 2002-04-08 04:38:13 EDT
More info: 
Behavior of kinput2 in Mozilla is identical in galeon. 
Comment 2 Warren Togami 2002-04-19 06:25:16 EDT
I found the solution!  It turns out that XIM input over-the-spot is not enabled
by default in Mozilla.  It should be enabled by default because all other web
browsers has it this way.

Simply modify your prefs.js to make input mode over-the-spot.
user_pref("xim.input_style", "over-the-spot");

Can this be added to the default settings of Red Hat mozilla packages?  This
seems to make Japanese work properly.

I am so relieved.  I have been agonizing over this problem for a year.
Comment 3 Warren Togami 2002-04-19 06:39:02 EDT
I added the same line to ~/galeon/mozilla/galeon/prefs.js and it now works in
Galeon too.

Please make it default in Galeon in addition to Mozilla.
Comment 4 Warren Togami 2002-05-09 04:11:08 EDT
Re-Tested: Still exists in Red Hat 7.3.

Please make over-the-spot default in future Mozilla packages, and this will be
fixed.
Comment 5 Warren Togami 2002-06-05 06:39:43 EDT
And please do not forget to add this to Galeon too.
Comment 6 Warren Togami 2002-07-15 07:13:59 EDT
Not yet fixed in Limbo.
Comment 7 Nakai 2002-07-22 06:51:55 EDT
This is a known but and known fix.
Mozilla team provided a patch for the
version of mozilla in RHL7.3 but in Limbo,
this bug comes up again.

Input method is very important feature
in browser (imagine when you cannot input
alphabets in mozilla), so I set the severity high.

I will attach the patch to set over-the-spot style default soon.
Comment 8 Nakai 2002-07-23 04:34:34 EDT
Created attachment 66485 [details]
mozilla-xim-style.patch (Should not be patched before %patch12)
Comment 9 Nakai 2002-07-23 04:40:31 EDT
Galeon issue should be another bug report because
it is a different rpm/maintainer.

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=69563
Comment 10 Christopher Blizzard 2002-07-24 18:01:25 EDT
Fixed in 1.0.1-10.

Note You need to log in before you can comment on or make changes to this bug.