Bug 623079 - Add storage usb and scsi non-hotplug with virt-manager failed
Add storage usb and scsi non-hotplug with virt-manager failed
Status: CLOSED DUPLICATE of bug 621933
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-11 05:26 EDT by weizhang
Modified: 2010-08-11 09:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 09:48:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description weizhang 2010-08-11 05:26:24 EDT
Description of problem:
There is an error on adding storage usb and scsi non-hotplug with virt-manager.
Here is the log on adding usb storage. The error on adding scsi is the same.
After remove the usb storage, the problem will disappear, but after remove the scsi storage, the problem still exists

~/.virt-manager/virt-manager.log

[Wed, 11 Aug 2010 10:29:00 virt-manager 2830] DEBUG (engine:876) Starting vm 'rr2'.
[Wed, 11 Aug 2010 10:29:00 virt-manager 2830] DEBUG (error:86) Uncaught Error: Error starting domain: internal error Process exited while reading console log output: char device redirected to /dev/pts/4
qemu-kvm: -device usb-storage,drive=drive-usb-disk0,id=usb-disk0: Parameter 'driver' expects a driver name
Try with argument '?' for a list.
 : Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 878, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 1313, in startup
    self._backend.create()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 333, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error Process exited while reading console log output: char device redirected to /dev/pts/4
qemu-kvm: -device usb-storage,drive=drive-usb-disk0,id=usb-disk0: Parameter 'driver' expects a driver name
Try with argument '?' for a list.


/var/log/messages

Aug 11 10:29:00 dhcp-66-92-126 kernel: device vnet1 entered promiscuous mode
Aug 11 10:29:00 dhcp-66-92-126 kernel: virbr0: topology change detected, propagating
Aug 11 10:29:00 dhcp-66-92-126 kernel: virbr0: port 2(vnet1) entering forwarding state
Aug 11 10:29:00 dhcp-66-92-126 NetworkManager[1620]: <warn> /sys/devices/virtual/net/vnet1: couldn't determine device driver; ignoring...
Aug 11 10:29:00 dhcp-66-92-126 kernel: virbr0: port 2(vnet1) entering disabled state
Aug 11 10:29:00 dhcp-66-92-126 kernel: device vnet1 left promiscuous mode
Aug 11 10:29:00 dhcp-66-92-126 kernel: virbr0: port 2(vnet1) entering disabled state
Aug 11 10:29:00 dhcp-66-92-126 libvirtd: 10:29:00.752: error : qemudReadLogOutput:2313 : internal error Process exited while reading console log output: char device redirected to /dev/pts/4#012qemu-kvm: -device usb-storage,drive=drive-usb-disk0,id=usb-disk0: Parameter 'driver' expects a driver name#012Try with argument '?' for a list.#012

Version-Release number of selected component (if applicable):
[root@dhcp-66-92-126 ~]# rpm -qa virt-manager
virt-manager-0.8.4-7.el6.noarch
[root@dhcp-66-92-126 ~]# rpm -qa libvirt
libvirt-0.8.1-21.el6.x86_64
[root@dhcp-66-92-126 ~]# uname -r
2.6.32-61.el6.x86_64
[root@dhcp-66-92-126 ~]# rpm -qa qemu-kvm
qemu-kvm-0.12.1.2-2.109.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.Launch virt-manager: #virt-manager
2.Double-click a vm and click the Shutdown->Force Off button in the Virtual Machine Details window.
3.Click the Hardware tab.
4.Click Add Hardware button
5.Select Storage in Hardware type droplist and click Forward.
6.Select managed or other existing storage and then click Browse to find a disk image.
7.Select USB disk in Device type then click Forward.
8.Click Finish button.
9.Reboot vm and check Hardware tab.
  
Actual results:
pop up an error

Expected results:
vm can be started successfully and the usb storage can be used.

Additional info:
Here is the xml I contrast.  
# diff test-before-add-scsi.xml test-after-add-scsi.xml 
27a28,33
>     <disk type='block' device='disk'>
>       <driver name='qemu' type='raw'/>
>       <source dev='/dev/sda8'/>
>       <target dev='sda' bus='scsi'/>
>       <address type='drive' controller='0' bus='0' unit='0'/>
>     </disk>
30a37,39
>     <controller type='scsi' index='0'>
>       <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>
>     </controller>

But after removing the scsi storage the following xml will not disappear so the vm can not be started.
>     <controller type='scsi' index='0'>
>       <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>
>     </controller>


# diff test1-before-add-usb.xml test1-after-add-usb.xml 
27a28,32
>     <disk type='file' device='disk'>
>       <driver name='qemu' type='raw'/>
>       <source file='/var/lib/libvirt/images/usb.img'/>
>       <target dev='sda' bus='usb'/>
>     </disk>
Comment 2 RHEL Product and Program Management 2010-08-11 05:58:49 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Daniel Berrange 2010-08-11 09:48:38 EDT
QEMU in RHEL6 no longer supports USB or SCSI disks, however, its error reporting for this is totally broken. See bug 621933

*** This bug has been marked as a duplicate of bug 621933 ***

Note You need to log in before you can comment on or make changes to this bug.